Bug 1465317 - [RFE] Support searching and filtering EFI boot machines when submitting bkr jobs via bkr workflow cmdline
[RFE] Support searching and filtering EFI boot machines when submitting bkr ...
Status: CLOSED DUPLICATE of bug 1112439
Product: Beaker
Classification: Community
Component: general (Show other bugs)
24
Unspecified Unspecified
urgent Severity high (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
: FutureFeature, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 04:03 EDT by Emma Wu
Modified: 2017-08-15 03:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-15 03:25:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Qiao Zhao 2017-07-02 21:53:09 EDT
Because more and more partner request UEFI issue, and qe still can't run automation case on uefi machine. And we didn't know which one is uefi boot machine unless we install system and login.
So, please take a look. Thanks in advance!
Comment 2 Dan Callaghan 2017-08-15 03:25:51 EDT
Although it is a bit of a hack, you can currently identify machines with EFI firmware (booting in EFI mode) by looking for key NETBOOT_METHOD with value "efigrub" or "grub2":

https://beaker.engineering.redhat.com/?systemsearch-0.table=Key%2FValue&systemsearch-0.keyvalue=NETBOOT_METHOD&systemsearch-0.operation=is&systemsearch-0.value=efigrub

https://beaker.engineering.redhat.com/?systemsearch-0.table=Key%2FValue&systemsearch-0.keyvalue=NETBOOT_METHOD&systemsearch-0.operation=is&systemsearch-0.value=grub2

Corresponding job XML filters are:

<key_value key="NETBOOT_METHOD" value="efigrub"/>

<key_value key="NETBOOT_METHOD" value="grub2"/>

For a less hackish proper solution to get detailed firmware info, there is bug 1112439.

*** This bug has been marked as a duplicate of bug 1112439 ***

Note You need to log in before you can comment on or make changes to this bug.