Bug 1465329 - VDSM report VF as dpdk while the VM is running
VDSM report VF as dpdk while the VM is running
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.20.0
x86_64 Linux
unspecified Severity urgent (vote)
: ovirt-4.2.0
: ---
Assigned To: Irit Goihman
Michael Burman
: Automation, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 04:49 EDT by Ori Ben Sasson
Modified: 2017-12-20 05:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 05:43:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78669 None None None 2017-06-27 04:53 EDT

  None (edit)
Description Ori Ben Sasson 2017-06-27 04:49:10 EDT
Description of problem:
VDSM report VF as dpdk as a free interface while the VM is running 

"dpdk0": {
            "ipv6autoconf": false, 
            "addr": "", 
            "dhcpv6": false, 
            "ipv6addrs": [], 
            "ipv4addrs": [], 
            "mtu": "", 
            "dhcpv4": false, 
            "netmask": "", 
            "ipv4defaultroute": false, 
            "pciaddr": "0000:05:10.0", 
            "hwaddr": "02:00:00:00:00:00", 
            "ipv6gateway": "::", 
            "gateway": ""
        }, 

Version-Release number of selected component (if applicable):
vdsm-4.20.1-67.git4721d69.el7.centos.x86_64

How reproducible:
100

Steps to Reproduce:
1. Create network with Passthrough
2. Set num of VF 1 
3. Add VF to VM
4. Start VM
5. run vdsm-client Host getCapabilities on VDSM

Actual results:
VDSM report VF as dpdk

Expected results:
VDSM shouldn't report VF as dpdk
Comment 1 Irit Goihman 2017-06-27 04:53:59 EDT
The fix has already been merged to master.
Comment 2 Red Hat Bugzilla Rules Engine 2017-06-27 08:22:56 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 3 Michael Burman 2017-07-13 04:48:14 EDT
Verified on - vdsm-4.20.1-180.git07508e2.el7.centos.x86_64 and  4.2.0-0.0.master.20170712143425.gitcb02bb5.el7.centos
Comment 4 Sandro Bonazzola 2017-12-20 05:43:10 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.