Bug 146534 - sysctl -a lists some errors which in turn mess up initscripts output
sysctl -a lists some errors which in turn mess up initscripts output
Status: CLOSED DUPLICATE of bug 144459
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-29 00:49 EST by Reuben Farrelly
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2005-01-29 00:49:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20050109 Fedora/1.7.5-3

Description of problem:
When starting up the network service on my server or when booting up, I get this logged:

[root@tornado init.d]# /etc/init.d/network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down interface gre0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Disabling IPv4 packet forwarding:  net.ipv4.ip_forward = 0
                                                           [  OK  ]
error: unknown error 22 reading key 'net.ipv6.route.flush'
error: unknown error 22 reading key 'net.ipv4.route.flush'
error: unknown error 22 reading key 'fs.binfmt_misc.register'
error: unknown error 22 reading key 'net.ipv6.route.flush'
error: unknown error 22 reading key 'net.ipv4.route.flush'
error: unknown error 22 reading key 'fs.binfmt_misc.register'
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:                                [  OK  ]
Bringing up interface gre0:                                [  OK  ]
[root@tornado init.d]# 

I've traced this to a problem with the output of sysctl -a.  In /etc/sysconfig/network-scripts/init.ipv6-global, sysctl -a is called and the output parsed.

This output includes the errors as above.



Version-Release number of selected component (if applicable):
procps-3.2.4-3

How reproducible:
Always

Steps to Reproduce:
You can reproduce this error by simply viewing the output of sysctl -a on the command line

ie:

..
net.ipv6.conf.all.accept_ra = 1
net.ipv6.conf.all.mtu = 1280
net.ipv6.conf.all.hop_limit = 64
net.ipv6.conf.all.forwarding = 0
error: unknown error 22 reading key 'net.ipv4.route.flush'
error: unknown error 22 reading key 'fs.binfmt_misc.register'
[root@tornado ~]#


Actual Results:  Errors :(

Expected Results:  The output should have been returned without error.

Additional info:

This bug has been present for a period of time, it is not a very recent regression.

[root@tornado ~]# rpm -q kernel-smp
kernel-smp-2.6.10-1.1115_FC4
[root@tornado ~]#

Also occurs when running non-Fedora kernels.
Comment 1 Karel Zak 2005-01-29 03:51:50 EST
See bug #144459.
Comment 2 Karel Zak 2005-01-29 04:12:01 EST

*** This bug has been marked as a duplicate of 144459 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:08:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.