Bug 1465386 - Undercloud installation failed with missing docker dependencies
Undercloud installation failed with missing docker dependencies
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: James Slagle
Gurenko Alex
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 07:08 EDT by Amit Ugol
Modified: 2017-06-27 08:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 08:36:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Ugol 2017-06-27 07:08:39 EDT
Description of problem:
Undercloud installtion failed on docker installation because the current images and repos have a dependency version mismatch. 


2017-06-27 13:40:39,057 INFO: ESC[mNotice: /Stage[main]/Main/User[docker_user]/groups: groups changed '' to ['docker']ESC[0m
2017-06-27 13:40:41,015 INFO: ESC[1;31mError: Execution of '/bin/yum -d 0 -e 0 -y install docker' returned 1: Error: Package: 7:device-mapper-event-1.02.140-6.el7.x86_64 (rhelosp-rhel-7.4-server)
2017-06-27 13:40:41,015 INFO:            Requires: device-mapper = 7:1.02.140-6.el7
2017-06-27 13:40:41,015 INFO:            Installed: 7:device-mapper-1.02.140-7.el7.x86_64 (installed)
2017-06-27 13:40:41,015 INFO:                device-mapper = 7:1.02.140-7.el7
2017-06-27 13:40:41,015 INFO:            Available: 7:device-mapper-1.02.140-6.el7.x86_64 (rhelosp-rhel-7.4-server)
2017-06-27 13:40:41,015 INFO:                device-mapper = 7:1.02.140-6.el7
Comment 1 Mike Burns 2017-06-27 08:36:28 EDT
Your rhel-guest-image is too new.  There is a mismatch between the image and yum repository configured by rhos-release.  You need -176 or older.

Note You need to log in before you can comment on or make changes to this bug.