Bug 146547 - nss_ldap and sfu35 very very slow
nss_ldap and sfu35 very very slow
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: nss_ldap (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-29 09:18 EST by Thorsten Scherf
Modified: 2015-01-07 19:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:08:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Scherf 2005-01-29 09:18:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
tried a ldapsearch against a windows 2003 machine with modified
schema, did it with services for unix version 3.5. 

everything works fine. did some objectclass and attribute mapping in
/etc/ldap.conf.

aksing for the entire userdatabase with getent passwd, or getent group
takes a long time to finish. I saw the windows users, but it really
takes a very long time to see complete listing. same problem with the
group database. 

after putting pam_ldap.so in /etc/pam.d/system-auth, I tried to su to
a windows user. nothing happened, su hangs for several minutes.

 

Version-Release number of selected component (if applicable):
nss_ldap-207-11

How reproducible:
Always

Steps to Reproduce:
1.configure a ldap client machine
2.install services for unix on a ads machine
3.try getent passwd, or getent group

Actual Results:  takes a long time to display the hole database,
authentication isn't possible or takes very very long

Expected Results:  see a quick user/group listing and do successfull
authentication against a windows user account.

Additional info:
Comment 1 RHEL Product and Program Management 2007-10-19 15:08:14 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.