Bug 1465480 - RFE -Use spectool to fetch sources
RFE -Use spectool to fetch sources
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Suchý
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 09:58 EDT by Alexis Jeandet
Modified: 2017-12-25 16:33 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-25 16:33:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample spec file (2.87 KB, text/plain)
2017-06-27 09:58 EDT, Alexis Jeandet
no flags Details

  None (edit)
Description Alexis Jeandet 2017-06-27 09:58:13 EDT
Created attachment 1292343 [details]
Sample spec file

Description of problem:

I have a spec file with sources  linked like this(Full spec file attached):

%global commit0 cf13c413f641b5816a4fc9cd4b2fb248c81bf2bd
URL:            https://github.com/verateam/%{name}
Source0: https://github.com/verateam/%{name}/archive/%{commit0}.tar.gz

Following this doc:
https://fedoraproject.org/wiki/Packaging:SourceURL?rd=Packaging/SourceURL#Git_Hosting_Services

locally it works with:
spectool -g -R vera.spec && rpmbuild -bs ./vera.spec && rpmbuild -bb ./vera.spec

Actual results:

It doesn't build on copr, because it doesn't fetch sources:
https://copr.fedorainfracloud.org/coprs/ajeandet/SciQLop/build/570647/

Expected results:


Additional info:
Comment 1 Miroslav Suchý 2017-06-27 11:09:59 EDT
This should be implemented in Mock first before we can do that in Copr.
Comment 2 Miroslav Suchý 2017-12-25 16:33:46 EST
In the mean time this have been implemented in rpkg-client
  https://pagure.io/rpkg-client
So you should create srpm using rpkg-client and then build it in Copr/Mock.

Note You need to log in before you can comment on or make changes to this bug.