Bug 1465499 - [RFE] Provide an OpenShift application node cluster object
[RFE] Provide an OpenShift application node cluster object
Status: CLOSED DUPLICATE of bug 1465501
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: cfme-future
Assigned To: Bronagh Sorota
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 10:20 EDT by Peter McGowan
Modified: 2017-06-27 10:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 10:22:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter McGowan 2017-06-27 10:20:33 EDT
Description of problem:
We can currently see individual OpenStack nodes in the WebUI, however we have no concept of which nodes make up the application node cluster. 

If we could have a way of modelling OpenShift nodes as a cluster, (rolling up node C&U metrics into cluster metrics), we could detect utilization (and trends) on this cluster as a single entity. We could make scaling decisions such as deploying additional nodes, or scaling-back nodes if the cluster was idle. Scaling back is particularly important when running OpenShift in a public cloud.

We would also need a way of generating a control alert based on real-time performance of this node cluster.
Comment 2 Peter McGowan 2017-06-27 10:22:14 EDT

*** This bug has been marked as a duplicate of bug 1465501 ***

Note You need to log in before you can comment on or make changes to this bug.