Bug 1465528 - RHEL7.4 Upgrade fails over RHGS 3.2.0 for samba ctdb packages
Summary: RHEL7.4 Upgrade fails over RHGS 3.2.0 for samba ctdb packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba
Version: rhgs-3.2
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: RHGS 3.2.0 Async
Assignee: Anoop C S
QA Contact: surabhi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-27 14:51 UTC by Vivek Das
Modified: 2017-08-01 07:47 UTC (History)
5 users (show)

Fixed In Version: samba-4.6.3-4.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 07:47:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:2338 normal SHIPPED_LIVE Moderate: samba security update 2017-08-01 11:46:05 UTC

Description Vivek Das 2017-06-27 14:51:09 UTC
Description of problem:

Over a RHGS 3.2.0 Setup with samba-ctdb if we try to upgrade to RHEL7.4 it fails for samba-ctdb packages as RHEL does not ship ctdb packages.

RHEL Samba version 4.6.2

Version-Release number of selected component (if applicable):
Samba 4.4.6-5
glusterfs-cli-3.8.4-18.4.el7rhgs.x86_64

How reproducible:


Steps to Reproduce:
1.Have a 3.2.0 Live samba-ctdb setup 
2.Add RHEL7.4 repo and yum upgrade
3.

Actual results:
yum upgrade fails for samba-ctdb packages

Expected results:


Additional info:
Error: Package: ctdb-4.4.6-5.el7rhgs.x86_64 (@rhel-x86_64-server-7-rh-gluster-3-samba)
           Requires: libtalloc-report-samba4.so(SAMBA_4.4.6)(64bit)
           Removing: samba-client-libs-4.4.6-5.el7rhgs.x86_64 (@rhel-x86_64-server-7-rh-gluster-3-samba)
               libtalloc-report-samba4.so(SAMBA_4.4.6)(64bit)
           Updated By: samba-client-libs-4.6.2-7.el7.x86_64 (download-node-02.eng.bos.redhat.com_rel-eng_RHEL-7.4-Snapshot-5.0_compose_Server_x86_64_os_)
              ~libtalloc-report-samba4.so(SAMBA_4.6.2)(64bit)
           Available: samba-client-libs-4.4.6-4.el7rhgs.x86_64 (rhel-x86_64-server-7-rh-gluster-3-samba)
               libtalloc-report-samba4.so(SAMBA_4.4.6)(64bit)
           Available: samba-client-libs-4.2.3-10.el7.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.2.3-11.el7_2.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.2.3-12.el7_2.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.2.4-6.el7rhgs.x86_64 (rhel-x86_64-server-7-rh-gluster-3-samba)
               Not found
           Available: samba-client-libs-4.2.4-9.1.el7rhgs.x86_64 (rhel-x86_64-server-7-rh-gluster-3-samba)
               Not found
           Available: samba-client-libs-4.2.4-13.el7rhgs.x86_64 (rhel-x86_64-server-7-rh-gluster-3-samba)
               Not found
           Available: samba-client-libs-4.2.4-15.el7rhgs.x86_64 (rhel-x86_64-server-7-rh-gluster-3-samba)
               Not found
           Available: samba-client-libs-4.2.10-6.el7_2.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.2.10-6.2.el7_2.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.2.10-7.el7_2.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.2.11-2.el7rhgs.x86_64 (rhel-x86_64-server-7-rh-gluster-3-samba)
               Not found
           Available: samba-client-libs-4.4.3-7.el7rhgs.x86_64 (rhel-x86_64-server-7-rh-gluster-3-samba)
              ~libtalloc-report-samba4.so(SAMBA_4.4.3)(64bit)
           Available: samba-client-libs-4.4.3-8.el7rhgs.x86_64 (rhel-x86_64-server-7-rh-gluster-3-samba)
              ~libtalloc-report-samba4.so(SAMBA_4.4.3)(64bit)
           Available: samba-client-libs-4.4.4-9.el7.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.4.4-12.el7_3.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.4.4-13.el7_3.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.4.4-14.el7_3.i686 (rhel-x86_64-server-7)
               Not found
           Available: samba-client-libs-4.4.5-3.el7rhgs.x86_64 (rhel-x86_64-server-7-rh-gluster-3-samba)
              ~libtalloc-report-samba4.so(SAMBA_4.4.5)(64bit)
Error: Package: ctdb-4.4.6-5.el7rhgs.x86_64 (@rhel-x86_64-server-7-rh-gluster-3-samba)

Comment 3 Anoop C S 2017-07-06 15:04:26 UTC
Changing to ON_QA status based on builds submitted for advisory RHBA-2017:29311-02 https://errata.devel.redhat.com/advisory/29311

Comment 4 Vivek Das 2017-07-24 08:29:18 UTC
Version: samba-4.6.3-4.el7rhgs
Looks good to me, Marking it as verified.

Comment 6 errata-xmlrpc 2017-08-01 07:47:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:2338


Note You need to log in before you can comment on or make changes to this bug.