Bug 146553 - Policy build tools parse apostrophe in comments
Policy build tools parse apostrophe in comments
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: selinux-policy-strict (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-29 10:36 EST by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 14:28:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2005-01-29 10:36:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
` and ' are parsed in comments as special characters

Version-Release number of selected component (if applicable):
selinux-policy-strict-1.21.5-2

How reproducible:
Always

Steps to Reproduce:
1. Type ' in a comment    

Actual Results:  I get warnings and ' ends up in policy.conf

Expected Results:  There should be no warnings and no ' in policy.conf.

Additional info:
Comment 1 Colin Walters 2005-01-31 14:28:54 EST
This is because the tools use m4.  Not a Fedora bug in any case;
discussion of changing the policy format should be done upstream.

Note You need to log in before you can comment on or make changes to this bug.