Bug 1465545 - scipy uses a bundled modified six and does not work correctly if using the system version
scipy uses a bundled modified six and does not work correctly if using the sy...
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: scipy (Show other bugs)
rh-python36
All Linux
unspecified Severity medium
: beta
: 3.0
Assigned To: Nikola Forró
Lukas Zachar
:
Depends On: 1459634
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 11:20 EDT by Nikola Forró
Modified: 2017-10-24 05:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: rh-python36-scipy-0.19.1-1.el6, rh-python36-scipy-0.19.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1459634
Environment:
Last Closed: 2017-10-24 05:52:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikola Forró 2017-06-27 11:20:43 EDT
+++ This bug was initially created as a clone of Bug #1459634 +++

Example command:

"""
$ scl enable rh-python35 'python -c "from scipy import ndimage"'
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/opt/rh/rh-python35/root/usr/lib64/python3.5/site-packages/scipy/ndimage/__init__.py", line 161, in <module>
    from .filters import *
  File "/opt/rh/rh-python35/root/usr/lib64/python3.5/site-packages/scipy/ndimage/filters.py", line 37, in <module>
    from scipy.misc import doccer
  File "/opt/rh/rh-python35/root/usr/lib64/python3.5/site-packages/scipy/misc/__init__.py", line 51, in <module>
    from scipy.special import comb, factorial, factorial2, factorialk
  File "/opt/rh/rh-python35/root/usr/lib64/python3.5/site-packages/scipy/special/__init__.py", line 629, in <module>
    from .basic import *
  File "/opt/rh/rh-python35/root/usr/lib64/python3.5/site-packages/scipy/special/basic.py", line 10, in <module>
    from six import xrange
ImportError: cannot import name 'xrange'
"""

The correction is to rebuild rh-python35-scipy backporting
http://pkgs.fedoraproject.org/cgit/rpms/scipy.git/commit/scipy.spec?id=b51885ba54e6a172fff77a2162becdfb4a83a15c
Comment 6 errata-xmlrpc 2017-10-24 05:52:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3021

Note You need to log in before you can comment on or make changes to this bug.