Bug 1465547 - Support for heterogeneous compute nodes
Support for heterogeneous compute nodes
Status: CLOSED DUPLICATE of bug 1418335
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
13.0 (Queens)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sean Merrow
Joe H. Rahme
: FutureFeature
Depends On:
Blocks: 1419948 1465537
  Show dependency treegraph
 
Reported: 2017-06-27 11:23 EDT by surya
Modified: 2017-07-25 21:56 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 21:56:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description surya 2017-06-27 11:23:25 EDT
Description of problem:
 Right now RH supports compute nodes with the same processor type(core count). 
Due to the variables novavcpupinset and dpdkcorelist we are not able to add compute nodes with different processor types and core count

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Sean Merrow 2017-07-06 11:06:43 EDT
Will confirm, but I believe this is already supported. You can have compute nodes with various resource configurations, then separate them via Host Aggregates.
Comment 2 Stephen Gordon 2017-07-19 09:01:54 EDT
(In reply to Sean Merrow from comment #1)
> Will confirm, but I believe this is already supported. You can have compute
> nodes with various resource configurations, then separate them via Host
> Aggregates.

You can, but the director settings for setting up e.g. DPDK don't understand such a topology.
Comment 3 Stephen Gordon 2017-07-25 10:28:48 EDT
Ollie is something like this possible using custom roles today?
Comment 4 Ollie Walsh 2017-07-25 21:56:50 EDT
(In reply to Stephen Gordon from comment #3)
> Ollie is something like this possible using custom roles today?

See the comments in https://bugzilla.redhat.com/show_bug.cgi?id=1418335

*** This bug has been marked as a duplicate of bug 1418335 ***

Note You need to log in before you can comment on or make changes to this bug.