Bug 1465562 - CFME crashes in case of description field not found
CFME crashes in case of description field not found
Status: VERIFIED
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 5.9.0
Assigned To: Yaacov Zamir
Shalom Naim
container:ui
: TestOnly, ZStream
Depends On:
Blocks: 1478527
  Show dependency treegraph
 
Reported: 2017-06-27 11:58 EDT by Shalom Naim
Modified: 2017-10-16 07:57 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1478527 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Container Management


Attachments (Terms of Use)
bug example (113.10 KB, image/png)
2017-06-27 11:58 EDT, Shalom Naim
no flags Details
cfme logs (1.88 MB, application/x-gzip)
2017-06-27 12:00 EDT, Shalom Naim
no flags Details

  None (edit)
Description Shalom Naim 2017-06-27 11:58:07 EDT
Created attachment 1292402 [details]
bug example

Description of problem:
when i tried to run matrices for logging project, CFME raise an error on descriptor_name not found

I was able to reproduce on openShift infra tenant

Steps to Reproduce:
1. remove casanra pod on openshift (oc delete pod hawkular-cassandra-1-u8app -n )openshift-infra 
2.wait until the pod raise again
3) try to get metrics for some project 
4) select one of the metrics

other option is to use hawkular-client-python (https://github.com/hawkular/hawkular-client-python) to supply metric without description tag
Comment 2 Shalom Naim 2017-06-27 12:00 EDT
Created attachment 1292403 [details]
cfme logs
Comment 3 Federico Simoncelli 2017-06-27 18:15:13 EDT
Nimrod, in case you need help to resolve this one you can ask help to Yaacov.
Comment 4 Yaacov Zamir 2017-07-02 08:42:16 EDT
submitted upstream:
https://github.com/ManageIQ/manageiq-ui-classic/pull/1638

Nimrod, Federico - Sorry, Shalom showed me this bug and I fixed it without knowing it was assign to Nimrod :-(
Comment 5 Yaacov Zamir 2017-07-10 02:33:52 EDT
merged upstream:
https://github.com/ManageIQ/manageiq-ui-classic/pull/1638

Note You need to log in before you can comment on or make changes to this bug.