Bug 1465577 - [RFE] Provide dry run capability
[RFE] Provide dry run capability
Status: CLOSED DUPLICATE of bug 1369270
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Angus Thomas
Amit Ugol
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 12:33 EDT by Jon Thomas
Modified: 2017-07-25 14:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-25 14:36:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Thomas 2017-06-27 12:33:28 EDT
This is split out from 

https://bugzilla.redhat.com/show_bug.cgi?id=1396227

Provide a description of changes that will be made and the end result when deploy and update operations are invoked

For director operations which will change the overcloud configuration, provide a report of changes that will be made and why, and then the overall result against these changes when complete. 


Provide a --dry-run flag  which would report on syntax and planned changes

For director operations which will change the overcloud configuration,  provide a dry-run flag whuch report of changes that will be made and why and any errors in syntax and arguments.
Comment 2 Jaromir Coufal 2017-07-25 14:36:08 EDT

*** This bug has been marked as a duplicate of bug 1369270 ***

Note You need to log in before you can comment on or make changes to this bug.