Bug 146563 - Cannot configure Python 2.4 on FC3
Cannot configure Python 2.4 on FC3
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-29 13:02 EST by Paul Watson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-29 14:12:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Watson 2005-01-29 13:02:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
config.log contains...

===
configure:1703: checking for c++
configure:1719: found /usr/bin/c++
configure:1729: result: c++
configure:1769: checking for C++ compiler default output file name
configure:1772: c++    conftest.cc  >&5
configure:1775: $? = 0
configure:1821: result: a.out
configure:1826: checking whether the C++ compiler works
configure:1832: ./a.out
./a.out: /usr/local/abinitio/lib/libgcc_s.so.1: version `GCC_3.3' not
found (required by /usr/lib/libstdc++.so.6)
configure:1835: $? = 1
configure:1844: error: cannot run C++ compiled programs.
===

I can use ./configure --without-cxx as suggested on the Python bug list.

===
Date: 2005-01-29 08:08
Sender: loewisSourceForge.net Donor
Logged In: YES 
user_id=21627

This is clearly a bug in your gcc installation - perhaps
some library is not up-to-date, or libstdc++ was compiled
with the wrong compiler. You should report this to the FC3
developers.

As a work-around, you can configure your Python --without-cxx.
===

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install fc3
2. download and expand Python 2.4
3. ./configure
    

Actual Results:  The configure script fails reporting that C++ objects
cannot be built because of a libstdc++ problem.

Expected Results:  ./configure would succeed and not report errors

Additional info:
Comment 1 Jakub Jelinek 2005-01-29 14:12:48 EST
/usr/local/abinitio/lib/libgcc_s.so.1: version `GCC_3.3' not found (required by
/usr/lib/libstdc++.so.6)

/usr/local/abinitio/lib/libgcc_s.so.1 is not part of Fedora Core, and is
older than the system libgcc_s.so.1 in /lib/.
The bug is that you are thus overriding a system library with an incompatible
(well, in this case likely just older) one.
You need to avoid that.
In this particular case I guess just rm -f /usr/local/abinitio/lib/libgcc_s*
would DTRT (perhaps make a backup copy of that).

But it is certainly not a bug in the distro, but a problem caused by badly
packaged 3rd party software.
Comment 2 Paul Watson 2005-01-29 21:48:22 EST
Yes.  My apologies.  The libgcc_s.so was from another third-party product, not
Python.  It appears to have been the source of the problem.  Sorry.

Note You need to log in before you can comment on or make changes to this bug.