Bug 1465633 - Several issues in Inkscape UI on Fedora 26
Several issues in Inkscape UI on Fedora 26
Status: CLOSED DUPLICATE of bug 1470788
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 15:40 EDT by pav
Modified: 2017-07-15 16:56 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-13 15:55:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing the issues (242.90 KB, image/jpeg)
2017-06-27 15:40 EDT, pav
no flags Details

  None (edit)
Description pav 2017-06-27 15:40:15 EDT
Created attachment 1292436 [details]
Screenshot showing the issues

Description of problem:

The Inkscape UI on Fedora 26 as it is currently is not usable on 
a laptop with a small-ish screen (1366x768).

Moreover, it appears there are some bugs appearing in it.

The issues are most clearly visible in the attached screenshot -- 
to summarize:

1) Popup menus (don't remember the Gtk term for this object) open 
at a wrong place on the screen, away from the button that opens them.

The place they open is different on the first time they are opened, 
and on subsequent times. The first time they appear close to the
center of the screen (see attached image), and on subsequent openings
it's either outside the screen (completely invisible) or at the correct
place --- not clear what determines this.

If the menu opens outside the screen, the menu button becomes unusable
until inkscape is closed and reopened.

2) The scrollbars are very wide and strange looking --- the handle is
narrow and the empty area is very big.

3) The right side panel is very big and cannot be made smaller.
I think it wasn't this big in previous inkscape versions.

Issue 1) and maybe 2) looks like a real bug. Issue 3) may be a design
mistake.


Version-Release number of selected component (if applicable):

$ rpm -qi inkscape
Name        : inkscape
Version     : 0.92.1
Release     : 4.20170510bzr15686.fc26


How reproducible:

2) and 3) always, and the initial wrong location of menu in 1) also always.
The out-of-screen(?) menu in 1) does not appear every time, unclear what 
determines it.

Steps to Reproduce:

Open Inkscape on Gnome Wayland on Fedora 26 (e.g. on a new user account 
to get default settings.) Not clear if issue 1) requires a smallish screen.

Actual results:

See above.

Expected results:

For 1) popup menu should open close to where the button is.

For 2) I would expect scroll bars to have the standard size (same size as 
the handle, without the surrounding "empty" space inside the scrollbar).

For 3), I would expect the sidebar either to relayout itself on shrinking, 
or have smaller elements (there's lots of empty space in the design).
Comment 1 Gwyn Ciesla 2017-07-13 15:55:42 EDT
Marking this as a duplicate of a later bug, because that bug has an upstream bug.

*** This bug has been marked as a duplicate of bug 1470788 ***
Comment 2 pav 2017-07-13 16:01:43 EDT
That UI issue looks like a different issue to me, but feel free to close if UI issues should be reported to upstream instead of here.
Comment 3 maarten 2017-07-13 17:31:37 EDT
I agree with pav@iki.fi, this bug is about the marker dropmenus having an offset when using them for the first time.

This deserves an upstream bug report on its own.

Note You need to log in before you can comment on or make changes to this bug.