Bug 1465657 - brltty base package adds a dependency on python2
brltty base package adds a dependency on python2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: brltty (Show other bugs)
26
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: depchain PPCTracker PYTHON3-UPSTREAM
  Show dependency treegraph
 
Reported: 2017-06-27 17:13 EDT by Peter Robinson
Modified: 2017-07-14 09:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: brltty-5.5-5.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-14 09:23:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ppc64le build failure (183.78 KB, text/plain)
2017-07-11 09:51 EDT, Gwyn Ciesla
no flags Details

  None (edit)
Description Peter Robinson 2017-06-27 17:13:00 EDT
The dependency should be on python3 not python2 it brings in an entire stack that's not default. 

The "python dependency is, unfortunately, correct, it's needed by the latex-access Contraction." should be split out into a sub package or it should use python3 because python3 is the default python stack in Fedora releases.
Comment 1 Fedora Update System 2017-07-11 09:46:12 EDT
brltty-5.5-5.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-16b93b066d
Comment 2 Gwyn Ciesla 2017-07-11 09:50:42 EDT
Update is out for f26, but the build dies with a java segfault on ppc64le.
Comment 3 Gwyn Ciesla 2017-07-11 09:51 EDT
Created attachment 1296262 [details]
ppc64le build failure
Comment 4 Peter Robinson 2017-07-11 09:54:59 EDT
Adding Power64 tracking bug so the POWER team are aware of the issue
Comment 5 Dan Horák 2017-07-11 10:07:33 EDT
the segfault could be the recent IFUNC issue with glibc 2.26 vs gcc (https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/UJDC6JZEXME2SWGEIAXAU6SE7RP5N3RH/)
Comment 6 Fedora Update System 2017-07-12 04:37:51 EDT
brltty-5.5-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-16b93b066d
Comment 7 Fedora Update System 2017-07-14 09:23:25 EDT
brltty-5.5-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.