Bug 146574 - Cannot install GNOME without KDE from kickstart installation
Summary: Cannot install GNOME without KDE from kickstart installation
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: desktop-printing (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-29 22:25 UTC by Duncan Innes
Modified: 2013-03-06 03:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:08:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Duncan Innes 2005-01-29 22:25:04 UTC
Description of problem:
When building a kickstart install file, it appears impossible to
install GNOME without installing KDE also.

Version-Release number of selected component (if applicable):


How reproducible:
Every time we create or edit the kickstart file and then perform a
network install, KDE is installed despite not being selected as an
installed component.

Steps to Reproduce:
1. Create kickstart file to install GNOME desktop but NOT KDE
2. Install OS using this kickstart file (we're doing a network boot
and then FTP install)
  
Actual results:
Several KDE components are installed (kdebase, kdelibs and some others
that I can't remember at the moment)

Expected results:
Expect full install of GNOME and zero install of KDE.

Additional info:
The bogey rpm seems to be desktop-printing which requires KDE for some
reason.  desktop-printing is part of the GNOME Desktop group and part
of the KDE Desktop group.

Comment 1 Duncan Innes 2005-01-29 22:55:22 UTC
Perhaps have the wrong component here.

I don't think that redhat-config-kickstart can do anything about the
problem.  

Is it more a fault of the actual desktop-printing rpm or the comps.xml
file?

Comment 2 Paul Nasrat 2005-02-14 04:45:27 UTC
I agree this is filed on the incorrect component - reassigning to desktop-printing

Comment 3 RHEL Product and Program Management 2007-10-19 19:08:11 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.