Bug 1465742 - Version 7.3 should be updated to 7.4
Version 7.3 should be updated to 7.4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor-ng (Show other bugs)
4.1.4
Unspecified Unspecified
unspecified Severity urgent
: ovirt-4.1.4
: ---
Assigned To: Ryan Barry
Qin Yuan
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 01:39 EDT by Qin Yuan
Modified: 2017-08-10 12:11 EDT (History)
15 users (show)

See Also:
Fixed In Version: redhat-release-virtualization-host-4.1-4.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 12:11:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qin Yuan 2017-06-28 01:39:37 EDT
Description of problem:
Install RHVH with rhel kernel 7.4, the version is still 7.3 in some places:

1) after boot into system:
Red Hat Virtualization Host 4.1 (el7.3)
kernel 3.10.0-686.el7.x86_64 on an x86_64

2) os-release:
[root@dell-per730-34 ~]# cat /etc/os-release
NAME="Red Hat Enterprise Linux"
VERSION="7.3"
VERSION_ID="7.3"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Red Hat Virtualization Host"
VARIANT_ID="ovirt-node"
PRETTY_NAME="Red Hat Virtualization Host 4.1 (el7.3)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.3:GA:hypervisor"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

# FIXME
REDHAT_BUGZILLA_PRODUCT="Red Hat Virtualization"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.3
REDHAT_SUPPORT_PRODUCT="Red Hat Virtualization"
REDHAT_SUPPORT_PRODUCT_VERSION=7.3

Version-Release number of selected component (if applicable):
RHVH-4.1-20170626.6-RHVH-x86_64-dvd1.iso

How reproducible:
100%

Steps to Reproduce:
1. Install RHVH-4.1-20170626.6-RHVH-x86_64-dvd1.iso
2. Check version as above

Actual results:
1. The version is 7.3

Expected results:
1. The version 7.3 should be replaced with 7.4

Additional info:
Comment 1 Ryan Barry 2017-06-28 07:02:31 EDT
This is expected.

Since redhat-release is never present (we obsolete it), redhat-release-virtualization-host must be updated to 7.4 once we expect to start releasing 7.4 images.

Since 4.1.3 will not be 7.4, and there's no alternate tag for this, it was not changed yet.
Comment 2 Qin Yuan 2017-07-25 01:15:51 EDT
Installed the latest iso "RHVH-4.1-20170723.1-RHVH-x86_64-dvd1.iso", the related infos were:

1) after boot into system:
Red Hat Virtualization Host 4.1 (el7.4)
kernel 3.10.0-693.el7.x86_64 on an x86_64

2)os-release
[root@localhost ~]# cat /etc/os-release 
NAME="Red Hat Enterprise Linux"
VERSION="7.4"
VERSION_ID="7.4"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Red Hat Virtualization Host"
VARIANT_ID="ovirt-node"
PRETTY_NAME="Red Hat Virtualization Host 4.1 (el7.4)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.4:GA:hypervisor"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

# FIXME
REDHAT_BUGZILLA_PRODUCT="Red Hat Virtualization"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.4
REDHAT_SUPPORT_PRODUCT="Red Hat Virtualization"
REDHAT_SUPPORT_PRODUCT_VERSION=7.4

Version 7.3 was updated to 7.4, the bug is verified.
Comment 4 errata-xmlrpc 2017-08-10 12:11:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2464

Note You need to log in before you can comment on or make changes to this bug.