Bug 146582 - Calc Navigation(?) toolbar unable to be turned off
Calc Navigation(?) toolbar unable to be turned off
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-29 18:36 EST by Steve Hall
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 04:48:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Hall 2005-01-29 18:36:27 EST
Description of problem:

Recent upgrade to 1.1.3, the Calc Navigation toolbar (input box for
URL, Find, etc.) is on, despite the preference checkbox being off.
Toggling it does nothing. Other toolbars can be turned on and off,
just not this one.
Comment 1 Caolan McNamara 2005-01-31 05:42:24 EST
This might just be a somewhat confusing name for the thing you want to disable.
There are normally three toolbars, right click on one of them to individually
directly enable and disable them.

The way its supposed to be is like so....

The one vertically to the left of the columns is the "Main toolbar", that one
normally has the find button on it.

There are two underneath the menubar, 
The top one is the "Function Bar", if you right click on it and choose "visible
buttons" you can easily add and remove the "Load URL" button for showing/hiding
the input box for URL, or you can disable the entire bar from the checklist.

The next one is the "Object bar", which normally has the font selection buttons.

The toolbar called "Navigation bar" shown in tools->customize" is shown when in
datapilot mode, e.g.  File->AutoPilot->Form->select Bibliography as data source
source, biblio as table, next->next until you see embedded Records in a
document, at that stage when you right click on a toolbar you'll see that
"Navigation bar" has joined the other three in the list, toggling that will
show/hide the "Record foo of foo" toolbar.

Is that helpful, or does what you see mismatch this or not work properly
Comment 2 Steve Hall 2005-01-31 08:22:18 EST
Ok, I think that helps me, although now I'm sure it is a bug. :)

It was the Function Bar's "Load URL" series of input boxes that I wanted to
disable. Odd that this "bar" would appear only after an upgrade. Also funny that
it isn't technically a bar with it's own name, a bar that can't be disabled
unless showing a previously hidden *button* on some other bar, and a bar that
can't be found with the others in the right-click or Tools > Configure >
Toolbars list of items.

I'm now happy, but surely this is either a UI or an upgrade bug?
Comment 3 Caolan McNamara 2005-02-01 04:47:22 EST
Strangely when I updated my openoffice.org to 1.1.3 that "open url" widget
didn't appear after the upgrade. That it's not called a "bar" by OOo is
admittedly confusing, but technically reasonable seeing as it can only be
included "inside" the real bars, and not standalone seperate from them.
Comment 4 Caolan McNamara 2005-02-01 04:48:51 EST
That said I'll tentatively mark it as not a bug but keep an eye out for similiar
appearences of non-enabled widgets on upgrades.

Note You need to log in before you can comment on or make changes to this bug.