Bug 146584 - geomview: segfault on start - x86_64
geomview: segfault on start - x86_64
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: geomview (Show other bugs)
3
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
:
Depends On:
Blocks: FE5Target
  Show dependency treegraph
 
Reported: 2005-01-29 19:26 EST by Rick L Vinyard Jr
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 09:35:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick L Vinyard Jr 2005-01-29 19:26:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Upstream bug? geomview segfaults at startup and provides the following
output:

Error reading "built-in camera geometry": can't seek back far enough
(on pipe?):
> ... appearance {linewidth 4}
> VECT
> 7 17 4
-^
> 2 2  2 2 2 2  5
Error reading "built-in light ray": can't seek back far enough (on pipe?):
> ... VECT  10 20  ...
-----------^
can't construct built-in light ray
InstCreate: Undefined option: 7119040
Geomview: internal error: Segmentation violation; dump core now (y/n)
[n] ? y
Segmentation fault


Version-Release number of selected component (if applicable):
geomview-1.8.1-10

How reproducible:
Always

Steps to Reproduce:
1. Install geomview
2. Start geomview
3.
    

Additional info:
Comment 1 Rex Dieter 2005-02-18 12:21:27 EST
I'll see about getting geomview removed from the x86_64 repo until
this is resolved.
Comment 2 Thorsten Leemhuis 2005-02-18 14:24:23 EST
I can confirm this problem. Will try to look into it at the weekend.
Comment 3 Gerald Kasner 2005-02-28 05:26:02 EST
This bug seems to be related to the new glibc (check malloc...)

I had the same bug in FC3 for x86. 
Setting the environment variable 

MALLOC_CHECK_=0

resulted in starting geomview fine. This is a rude solution, 
but maybe a hint where to look for.

Regards, Gerald
Comment 4 Rex Dieter 2005-02-28 08:43:59 EST
Gerald, you say you had similar problems in FC3/x86?  Do tell more
details (or better yet, open another bug report).
Comment 5 Gerald Kasner 2005-03-01 08:49:37 EST
Yes, the same problem on FC3/x86. But yesterday I forgot to mention that 
I was NOT using the SRPMS from the extra repository, but a snapshot from 
http://www.ee.surrey.ac.uk/Personal/L.Wood/software/SaVi/src/unreleased/
geomview-snapshot-2004-02-21.tar.gz

I had to add LIBS=-lm in front of ./configure. 
Then make, make install.

This version crashes with MALLOC_CHECK_=1 as follows:
malloc: using debugging hooks
Reading VECT from "built-in camera geometry": can't read header counts
[no text available]
Error reading "built-in light ray": can't seek back far enough (on pipe?):
> ... VECT  10 20  ...
-----------^
can't construct built-in light ray
malloc: using debugging hooks
Geomview: internal error: Segmentation violation; dump core now (y/n)
[n] ?

With MALLOC_CHECK_=0 I get 
Error reading "built-in camera geometry": can't seek back far enough
(on pipe?):
> ... appearance {linewidth 4}
> VECT
> 7 17 4
-^
> 2 2  2 2 2 2  5
Error reading "built-in light ray": can't seek back far enough (on pipe?):
> ... VECT  10 20  ...
-----------^
can't construct built-in light ray

but the camera-window, tools-window and main-window appear.

I played with the examples, no chrashes.

Gerald

 
Comment 6 Rex Dieter 2005-03-01 09:41:57 EST
Thanks Gerald.  I'll look into getting a geomview-snapshot build
pushed and see if I can get the upstream developers' eyes on this.
Comment 7 Thorsten Leemhuis 2005-07-24 12:21:34 EDT
Ping -- what's the status of this?
Comment 8 Rick L Vinyard Jr 2005-07-24 12:38:53 EDT
i386 version works on x86_64, but the x86_64 version (as of 2005-07-24) gives:

InstCreate: Undefined option: 7098544
Geomview: internal error: Segmentation violation; dump core now (y/n) [n] ?

and dumps back to command line.
Comment 9 Rex Dieter 2006-01-03 10:28:37 EST
20040421 geomview(1.8.2-alpha) snapshot built and pushed to FC-4/devel repos. 
Comment 10 Rex Dieter 2006-01-04 11:31:34 EST
Let me know how the new build works.
Comment 11 Rex Dieter 2006-01-31 09:35:01 EST
Closing, lack of feedback.  

Feel free to reopen if you have additional comment.

Note You need to log in before you can comment on or make changes to this bug.