This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1465915 - RHEL 6.9 update breaks createrepo
RHEL 6.9 update breaks createrepo
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: createrepo (Show other bugs)
6.9
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Valentina Mukhamedzhanova
Eva Mrakova
Marc Muehlfeld
: Regression, ZStream
Depends On: 1434369
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 08:41 EDT by Oneata Mircea Teodor
Modified: 2017-07-13 02:51 EDT (History)
24 users (show)

See Also:
Fixed In Version: createrepo-0.9.9-27.el6_9
Doc Type: Bug Fix
Doc Text:
Due to a bug, the "createrepo -C --update" command previously failed with the following error: AttributeError: MetaDataGenerator instance has no attribute 'oldData' A check has been added to the code. As a result, the command now runs correctly.
Story Points: ---
Clone Of: 1434369
Environment:
Last Closed: 2017-07-11 14:50:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 23016 None None None 2017-06-28 08:41 EDT

  None (edit)
Description Oneata Mircea Teodor 2017-06-28 08:41:44 EDT
This bug has been copied from bug #1434369 and has been proposed
to be backported to 6.9 z-stream (EUS).
Comment 7 errata-xmlrpc 2017-07-11 14:50:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1729

Note You need to log in before you can comment on or make changes to this bug.