Bug 146596 - libdv uses text relocations in DSO
libdv uses text relocations in DSO
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libdv (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-30 03:03 EST by Warren Togami
Modified: 2013-01-09 22:38 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 10:49:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2005-01-30 03:03:51 EST
Description of problem:
Ulrich Drepper said that libdv currently uses text relocations in DSO's, which
is bad because it will soon be disallowed by selinux policy.  libdv must be
fixed and (harder part) verified.
Comment 1 Warren Togami 2005-10-17 22:56:30 EDT
foo, could you please post the link to the document that describes this problem
in general?
Comment 2 Warren Togami 2006-03-06 10:35:25 EST
No progress on this, moving to FC6.
Comment 3 Jeremy Katz 2006-09-21 16:17:42 EDT
Has this been fixed?
Comment 4 Jarod Wilson 2006-09-22 15:34:00 EDT
In response to comment #1, I think this is it:
http://people.redhat.com/drepper/textrelocs.html

As for progres... So far as I can tell, this only impacts i386 builds. According
to eu-findtextrel, the problem is that the i386 assembly bits weren't compiled
with -fPIC, but forcing the build to use -fPIC still results in the same
message. Assembly isn't exactly my thing, so I'm not sure how to fix this, short
of passing the --disable-asm flag. Using --disable-asm does eliminate the text
relocations, but I'm not sure how seriously that would impact performance. I
suppose slower performance is better than it not working at all. Thoughts?

In the mean time, It would seem best to just pass --disable-asm on i386 builds.
Upstream has actually come back to life a bit of late, so maybe I can get
someone there to take a peek so we can turn asm on i386 back on later.
Comment 5 Mike Frysinger 2006-09-22 16:37:01 EDT
building asm files with -fPIC doesnt really have any meaning as the symbol
references are hand coded ... the asm itself is broken, not the build
Comment 6 Jarod Wilson 2006-09-25 16:51:47 EDT
(In reply to comment #5)
> building asm files with -fPIC doesnt really have any meaning as the symbol
> references are hand coded ... the asm itself is broken, not the build

That's sort of what I'd figured from my vague recollection of mmx assembly code.

/me makes mental note to file a bz for eu-findtextrel...

Mike, you mentioned on the libdv-dev mailing list you had some patches that were
not yet merged. Can you point me towards copies, by chance? The sf.net mailing
list archives are... less than fantastic...
Comment 7 Jesse Keating 2006-10-03 17:09:12 EDT
any further status?  Is this really blocking the release of fc6?
Comment 8 Jarod Wilson 2006-10-03 17:26:26 EDT
For the moment, we're going with an i386 build that has asm disabled. It'll be
slower, not sure how much, and when there's a text reloc fix available, we'll
incorporate it in a -updates build.
Comment 9 Jarod Wilson 2007-01-19 16:19:43 EST
Bumping to libdv 1.0.0 and applying PIC patch from Mike:

http://bugs.gentoo.org/show_bug.cgi?id=121871
http://bugs.gentoo.org/attachment.cgi?id=98094

New rawhide and FC6 updates-testing builds to beat on are coming shortly. Test
i386 build reports no more text relocations:

$ eu-findtextrel /usr/lib/libdv.so.4*
eu-findtextrel: no text relocations reported in '/usr/lib/libdv.so.4'
eu-findtextrel: no text relocations reported in '/usr/lib/libdv.so.4.0.3'

Even better, I'm still able to decode dv material w/o a problem (playdv
sample.dv), so thus far, lookin' good (plus, its been enabled in Gentoo for
almost two months now).

Note You need to log in before you can comment on or make changes to this bug.