Bug 1466035 - Registry health checks fail with error http2: no cached connection was available
Registry health checks fail with error http2: no cached connection was available
Status: CLOSED DUPLICATE of bug 1454858
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Derek Carr
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 15:40 EDT by Ryan Howe
Modified: 2017-12-23 09:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-28 16:16:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Howe 2017-06-28 15:40:25 EDT
Description of problem:

 Randomly one of the health checks on the registry fails. 


Version-Release number of selected component (if applicable):
OCP 3.5.5.8

How reproducible:
Happens intermittently 

Actual results:

 atomic-openshift-node[36648][prober.go:106] Readiness probe for "docker-registry-12-lknh8_default(91642388-5c0a-11e7-9c80-005056961e9a):registry" failed (failure): Get https://10.1.4.60:5000/healthz: http2: no cached connection was available

 dockerd-current[1501]: 10.1.4.1 - - [28/Jun/2017:17:17:01 +0000] "GET /healthz HTTP/2.0" 200 0 "" "Go-http-client/2.0"

Expected results:

 dockerd-current[1501]: 10.1.4.1 - - [28/Jun/2017:17:17:11 +0000] "GET /healthz HTTP/2.0" 200 0 "" "Go-http-client/2.0"
 dockerd-current[1501]: 10.1.4.1 - - [28/Jun/2017:17:17:11 +0000] "GET /healthz HTTP/2.0" 200 0 "" "Go-http-client/2.0"


Additional info:

Possible upstream issue: 

  https://github.com/golang/go/issues/16582
  https://github.com/golang/go/commit/7a622740655bb5fcbd160eb96887032314842e6e
Comment 2 Derek Carr 2017-06-28 16:16:05 EDT

*** This bug has been marked as a duplicate of bug 1454858 ***
Comment 3 Derek Carr 2017-06-28 16:16:34 EDT
See: https://bugzilla.redhat.com/show_bug.cgi?id=1454858#c2

Note You need to log in before you can comment on or make changes to this bug.