Bug 1466042 - Accessing WebUI redirects to fqdn hostname
Accessing WebUI redirects to fqdn hostname
Status: CLOSED DUPLICATE of bug 1466014
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Depends On:
  Show dependency treegraph
Reported: 2017-06-28 16:35 EDT by Sean V. Thompson
Modified: 2017-07-28 11:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-07-28 11:41:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Sean V. Thompson 2017-06-28 16:35:44 EDT
Description of problem:
I have to NAT in to my network to access my idm server. When I setup port forwarding I should be able to port forward to idm.example.com:443 to access the webui and login. However, I get redirected to the FQDN:443 (removing the port) and that fqdn and port aren't routable on the external network.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Setup idm
2. Try accessing the web console using the ip address (ex.

Actual results:
redirects to https://idm.example.com/ipa/ui

Expected results:
should redirect to

Additional info:
This works fine using Ansible Tower and Satellite 6. I can access and login to the webui from an external network using port forwarding.
Comment 2 Martin Bašti 2017-07-03 04:16:12 EDT
For external network you may need https://www.adelton.com/freeipa/freeipa-behind-proxy-with-different-name
Comment 3 Petr Vobornik 2017-07-17 03:40:11 EDT
This is an intended behavior. There is a redirection rule in /etc/httpd/conf.d/ipa-rewrite.conf which does it.

Without it Kerberos authentication may not work.
Comment 4 Petr Vobornik 2017-07-28 11:41:09 EDT

*** This bug has been marked as a duplicate of bug 1466014 ***

Note You need to log in before you can comment on or make changes to this bug.