Bug 146606 - system-config-bind 4.0.0-1 missing dependency
system-config-bind 4.0.0-1 missing dependency
Status: CLOSED DUPLICATE of bug 146475
Product: Fedora
Classification: Fedora
Component: system-config-bind (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-30 11:10 EST by Patrice Dumas
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:08:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2005-01-30 11:10:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I have a pure fc3 system, but there is a bug with system-config-bind
that renders it useless, bug #139985. It is fixed in rawhide but not
in updates. Therefore I tried to install the rawhide
system-config-bind, but there is a backtrace showing missing imports.
Maybe this is due to missing dependancies:

[root@chapelle named]# system-config-bind
Traceback (most recent call last):
  File "/usr/sbin/system-config-bind", line 32, in ?
    from BIND import *
  File "/usr/share/system-config-bind/BIND.py", line 12, in ?
    import Lookup
  File "/usr/share/system-config-bind/Lookup.py", line 136, in ?
    localhost = Lookup()
  File "/usr/share/system-config-bind/Lookup.py", line 125, in __init__
    (name,s.addr) = s.lookup_addr(host)
TypeError: unpack non-sequence


Version-Release number of selected component (if applicable):
system-config-bind-4.0.0-1

How reproducible:
Always

Steps to Reproduce:
1. install system-config-bind-4.0.0-1 on a fc3 system
2. run system-config-bind
3.
    

Actual Results:  A traceback

[root@chapelle named]# system-config-bind
Traceback (most recent call last):
  File "/usr/sbin/system-config-bind", line 32, in ?
    from BIND import *
  File "/usr/share/system-config-bind/BIND.py", line 12, in ?
    import Lookup
  File "/usr/share/system-config-bind/Lookup.py", line 136, in ?
    localhost = Lookup()
  File "/usr/share/system-config-bind/Lookup.py", line 125, in __init__
    (name,s.addr) = s.lookup_addr(host)
TypeError: unpack non-sequence


Additional info:

I flagged this bug as normal although it is in rawhide only as the
system-config-bind shipped with fc3 doesn't work.
Comment 1 Jason Vas Dias 2005-01-30 13:10:47 EST
Sorry about that! This happens if your hostname (output of 'hostname'
command) is not known in DNS, or is not 'localhost' and no local
interface has an address with a DNS PTR mapping - which is a bad idea
for a nameserver, BTW.
This is now fixed in system-config-bind-4.0.0-2, which will be in 
FC4/rawhide 2005-02-02, and which can be downloaded from:
   http://people.redhat.com/~jvdias/system-config-bind
The first thing you should do with the tool is click on 'Import' to
import your /etc/hosts file into the local DNS configuration.


*** This bug has been marked as a duplicate of 146475 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:08:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.