Bug 1466062 - Dynamic dialog set as read-only is able to be edited in Service portal
Dynamic dialog set as read-only is able to be edited in Service portal
Status: CLOSED DUPLICATE of bug 1466340
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service (Show other bugs)
5.8.0
All All
medium Severity medium
: GA
: cfme-future
Assigned To: Chris Hale
Dave Johnson
:
Depends On: 1466340
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 18:33 EDT by Ryan Spagnola
Modified: 2017-07-06 12:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 12:54:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Ryan Spagnola 2017-06-28 18:33:19 EDT
Description of problem:
Customer has a catalog with a date control element to set service retires date.  This is a dynamic dialog which display the date but set as read only.  The catalog works fine when ordering it on the regular console.

But if user order it on the self-service portal, the same date control element in the dialog become editable.  When user submit the order, the value of the date is also not set.  The order is submitted to provisioning and the service will be provisioned without a retirement date.

When viewing the request on the regular console, the page will come up with error (see attached screenshot)

Version-Release number of selected component (if applicable):
5.8

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 Chris Kacerguis 2017-07-06 12:54:53 EDT

*** This bug has been marked as a duplicate of bug 1466340 ***

Note You need to log in before you can comment on or make changes to this bug.