Bug 1466064 - openstack-ironic: After major upgrade + reboot of the undercloud openstack-ironic-inspector-dnsmasq.service fails to load.
openstack-ironic: After major upgrade + reboot of the undercloud openstack-ir...
Status: CLOSED DUPLICATE of bug 1452610
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic (Show other bugs)
10.0 (Newton)
Unspecified Unspecified
unspecified Severity unspecified
: async
: 10.0 (Newton)
Assigned To: RHOS Maint
mlammon
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 19:12 EDT by Alexander Chuzhoy
Modified: 2017-06-29 05:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-29 05:36:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport from the undercloud node (15.74 MB, application/x-xz)
2017-06-28 19:18 EDT, Alexander Chuzhoy
no flags Details

  None (edit)
Description Alexander Chuzhoy 2017-06-28 19:12:18 EDT
openstack-ironic: After major upgrade + reboot of the undercloud openstack-ironic-inspector-dnsmasq.service fails to load.

Environment:
openstack-puppet-modules-9.3.0-1.el7ost.noarch
instack-undercloud-5.3.0-1.el7ost.noarch
openstack-tripleo-heat-templates-compat-2.0.0-41.el7ost.noarch
openstack-tripleo-heat-templates-5.2.0-20.el7ost.noarch
python-ironicclient-1.7.1-1.el7ost.noarch
python-ironic-tests-6.2.3-1.el7ost.noarch
openstack-ironic-common-6.2.3-1.el7ost.noarch
openstack-ironic-conductor-6.2.3-1.el7ost.noarch
puppet-ironic-9.5.0-1.el7ost.noarch
python-ironic-lib-2.1.3-1.el7ost.noarch
openstack-ironic-api-6.2.3-1.el7ost.noarch
openstack-ironic-inspector-4.2.1-3.el7ost.noarch
python-ironic-inspector-client-1.10.0-1.el7ost.noarch

Steps to reproduce:
1. Upgrade undercloud from OSP9 to OSP10
2. reboot the undercloud (the upgrade included update from ovs 2.5 to ovs 2.6)
3. Check running services

Result:
[stack@director ~]$ sudo systemctl list-units "openstack*" "neutron*" "openvswitch*"
  UNIT                                       LOAD   ACTIVE     SUB     JOB   DESCRIPTION
  neutron-dhcp-agent.service                 loaded active     running       OpenStack Neutron DHCP Agent
  neutron-openvswitch-agent.service          loaded active     running       OpenStack Neutron Open vSwitch Agent
  neutron-ovs-cleanup.service                loaded active     exited        OpenStack Neutron Open vSwitch Cleanup Utility
  neutron-server.service                     loaded active     running       OpenStack Neutron Server
  openstack-aodh-evaluator.service           loaded active     running       OpenStack Alarm evaluator service
  openstack-aodh-listener.service            loaded active     running       OpenStack Alarm listener service
  openstack-aodh-notifier.service            loaded active     running       OpenStack Alarm notifier service
  openstack-ceilometer-central.service       loaded active     running       OpenStack ceilometer central agent
  openstack-ceilometer-collector.service     loaded active     running       OpenStack ceilometer collection service
  openstack-ceilometer-notification.service  loaded active     running       OpenStack ceilometer notification agent
  openstack-glance-api.service               loaded active     running       OpenStack Image Service (code-named Glance) API server
  openstack-glance-registry.service          loaded active     running       OpenStack Image Service (code-named Glance) Registry server
  openstack-heat-api-cfn.service             loaded active     running       Openstack Heat CFN-compatible API Service
  openstack-heat-api.service                 loaded active     running       OpenStack Heat API Service
  openstack-heat-engine.service              loaded active     running       Openstack Heat Engine Service
  openstack-ironic-api.service               loaded active     running       OpenStack Ironic API service
  openstack-ironic-conductor.service         loaded active     running       OpenStack Ironic Conductor service
● openstack-ironic-inspector-dnsmasq.service loaded failed     failed        PXE boot dnsmasq service for Ironic Inspector
  openstack-ironic-inspector.service         loaded active     running       Hardware introspection service for OpenStack Ironic
  openstack-mistral-api.service              loaded active     running       Mistral API Server
  openstack-mistral-engine.service           loaded active     running       Mistral Engine Server
  openstack-mistral-executor.service         loaded active     running       Mistral Executor Server
  openstack-nova-api.service                 loaded active     running       OpenStack Nova API Server
  openstack-nova-cert.service                loaded active     running       OpenStack Nova Cert Server
  openstack-nova-compute.service             loaded activating start   start OpenStack Nova Compute Server
  openstack-nova-conductor.service           loaded active     running       OpenStack Nova Conductor Server
  openstack-nova-scheduler.service           loaded active     running       OpenStack Nova Scheduler Server
  openstack-swift-account-reaper.service     loaded active     running       OpenStack Object Storage (swift) - Account Reaper
  openstack-swift-account.service            loaded active     running       OpenStack Object Storage (swift) - Account Server
  openstack-swift-container-updater.service  loaded active     running       OpenStack Object Storage (swift) - Container Updater
  openstack-swift-container.service          loaded active     running       OpenStack Object Storage (swift) - Container Server
  openstack-swift-object-updater.service     loaded active     running       OpenStack Object Storage (swift) - Object Updater
  openstack-swift-object.service             loaded active     running       OpenStack Object Storage (swift) - Object Server
  openstack-swift-proxy.service              loaded active     running       OpenStack Object Storage (swift) - Proxy Server
  openstack-zaqar.service                    loaded active     running       OpenStack Message Queuing Service (code-named Zaqar) Server
  openstack-zaqar@1.service                  loaded active     running       OpenStack Message Queuing Service (code-named Zaqar) Server Instance 1
  openvswitch.service                        loaded active     exited        Open vSwitch

LOAD   = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.



Expected result:
openstack-ironic-inspector-dnsmasq.service shouldn't have status failed.


[stack@director ~]$ sudo journalctl -u openstack-ironic-inspector-dnsmasq.service -perr
-- Logs begin at Tue 2017-06-27 12:59:16 CDT, end at Wed 2017-06-28 18:04:59 CDT. --
Jun 27 14:14:15 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.150
Jun 27 14:14:25 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.151
Jun 27 14:14:36 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.152
Jun 27 14:14:39 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.153
Jun 27 14:14:52 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.154
Jun 27 14:15:01 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.155
Jun 27 14:15:04 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.156
Jun 27 14:16:28 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.157
Jun 27 14:16:39 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.158
Jun 27 14:25:13 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.136
Jun 27 14:25:16 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.131
Jun 27 14:25:18 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.133
Jun 27 14:25:23 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.129
Jun 27 14:25:24 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.130
Jun 27 14:25:24 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.134
Jun 27 14:25:31 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.128
Jun 27 14:27:31 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.132
Jun 27 14:27:32 director.fv1dci.org dnsmasq-tftp[23923]: error 0 TFTP Aborted received from 192.168.120.135
-- Reboot --
Jun 28 14:45:31 director.fv1dci.org systemd[1]: Failed to start PXE boot dnsmasq service for Ironic Inspector.
-- Reboot --
Jun 28 17:53:15 director.fv1dci.org dnsmasq[930]: unknown interface br-ctlplane
Jun 28 17:53:15 director.fv1dci.org dnsmasq[930]: FAILED to start up
Jun 28 17:53:15 director.fv1dci.org systemd[1]: Failed to start PXE boot dnsmasq service for Ironic Inspector.



[stack@director ~]$ sudo ip a show dev br-ctlplane
9: br-ctlplane: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN qlen 1000
    link/ether 52:54:00:00:6d:8a brd ff:ff:ff:ff:ff:ff
    inet 192.168.120.101/24 brd 192.168.120.255 scope global br-ctlplane
       valid_lft forever preferred_lft forever
    inet6 fe80::5054:ff:fe00:6d8a/64 scope link 
       valid_lft forever preferred_lft forever




Workaround: Running  "sudo systemctl start openstack-ironic-inspector-dnsmasq.service" brings the service up.

The services re-appears as failed upon subsequent reboots.
Comment 1 Alexander Chuzhoy 2017-06-28 19:18 EDT
Created attachment 1292711 [details]
sosreport from the undercloud node
Comment 2 Dmitry Tantsur 2017-06-29 05:36:31 EDT
Thanks, I think it's a know issue.

*** This bug has been marked as a duplicate of bug 1452610 ***

Note You need to log in before you can comment on or make changes to this bug.