Bug 1466098 - Error on shutdown - Kernel is not configured for semaphore (System V IPC). Not using udev synchronization code
Error on shutdown - Kernel is not configured for semaphore (System V IPC). N...
Status: CLOSED DUPLICATE of bug 1385432
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 22:57 EDT by Gleidson Baleeiro
Modified: 2017-06-29 15:16 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-29 15:16:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error message (4.65 MB, image/jpeg)
2017-06-28 22:57 EDT, Gleidson Baleeiro
no flags Details

  None (edit)
Description Gleidson Baleeiro 2017-06-28 22:57:41 EDT
Created attachment 1292768 [details]
Error message

Description of problem:

Error message on shutdown (Kernel is not configured for semaphore (System V IPC). Not using udev synchronization code) 

Attached image with error.

I already ran relabel thinking it could be selinux, as reported in another bug, but the problem persisted.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Shutdown 

Actual results:
Error message on shutdown and slow boot.

Expected results:
Shutdown without error messages.

Additional info:

systemd-analyze critical-chain
graphical.target @1min 15.063s
└─bumblebee-nvidia.service @1min 14.734s +328ms
  └─multi-user.target @1min 14.734s
    └─atd.service @43.889s
      └─systemd-user-sessions.service @43.536s +263ms
        └─remote-fs.target @43.532s
          └─remote-fs-pre.target @43.531s
            └─iscsi-shutdown.service @43.526s
              └─network.target @43.409s
                └─wpa_supplicant.service @51.971s +182ms
                  └─dbus.service @28.941s
                    └─basic.target @27.839s
                      └─paths.target @27.839s
                        └─cups.path @27.839s
                          └─sysinit.target @27.788s
                            └─systemd-update-utmp.service @27.713s +74ms
                              └─auditd.service @27.128s +580ms
                                └─systemd-tmpfiles-setup.service @25.320s +1.733s
                                  └─systemd-journal-flush.service @3.349s +21.968s
                                    └─systemd-remount-fs.service @3.204s +130ms
                                      └─systemd-fsck-root.service @584542y 2w 2d 20h 1min 47.182s +254ms
                                        └─system.slice
                                          └─-.slice

The line "systemd-fsck-root.service @584542y 2w 2d 20h 1min 47.182s +254ms" caught my attention.

uname -a 

Linux inspiron7000 4.11.7-300.fc26.x86_64 #1 SMP Mon Jun 26 14:54:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

screenfetch 

           /:-------------:\          gleidson@inspiron7000
        :-------------------::        OS: Fedora 26 TwentySix
      :-----------/shhOHbmp---:\      Kernel: x86_64 Linux 4.11.7-300.fc26.x86_64
    /-----------omMMMNNNMMD  ---:     Uptime: 53m
   :-----------sMMMMNMNMP.    ---:    Packages: 2614
  :-----------:MMMdP-------    ---\   Shell: bash 4.4.12
 ,------------:MMMd--------    ---:   DE: GNOME 
 :------------:MMMd-------    .---:   WM: 
 :----    oNMMMMMMMMMNho     .----:   GTK Theme: Adwaita [GTK2/3]
 :--     .+shhhMMMmhhy++   .------/   Icon Theme: Adwaita
 :-    -------:MMMd--------------:    Font: Cantarell 11
 :-   --------/MMMd-------------;     CPU: Intel Core i7-7500U @ 4x 3.5GHz [25.0°C]
 :-    ------/hMMMy------------:      GPU: intel
 :-- :dMNdhhdNMMNo------------;       RAM: 1892MiB / 15943MiB
 :---:sdNMMMMNds:------------:       
 :------:://:-------------::         
 :---------------------://
Comment 1 Gleidson Baleeiro 2017-06-28 23:03:25 EDT
journalctl --disk-usage: Archived and active journals take up 120.0M in the file system.
Comment 2 Gleidson Baleeiro 2017-06-29 08:06:20 EDT
my system is using LVM+LUKS

ilesystem               Size  Used Avail Use% Mounted on
devtmpfs                 7.8G     0  7.8G   0% /dev
tmpfs                    7.8G  100K  7.8G   1% /dev/shm
tmpfs                    7.8G  2.3M  7.8G   1% /run
tmpfs                    7.8G     0  7.8G   0% /sys/fs/cgroup
/dev/mapper/fedora-root   50G   13G   34G  28% /
tmpfs                    7.8G  348K  7.8G   1% /tmp
/dev/mapper/fedora-home  856G  144G  669G  18% /home
/dev/sda3                976M  171M  738M  19% /boot
/dev/sda1                496M   34M  463M   7% /boot/efi
tmpfs                    1.6G   20K  1.6G   1% /run/user/42
tmpfs                    1.6G  8.4M  1.6G   1% /run/user/1000
Comment 3 Laura Abbott 2017-06-29 15:16:41 EDT
The 'kernel not configured' is a misleading error message, this has nothing to do with the kernel but is related to an ongoing dracut problem.

*** This bug has been marked as a duplicate of bug 1385432 ***

Note You need to log in before you can comment on or make changes to this bug.