Bug 14661 - gnome-config links against libdb1, packaged programs are linked against libdb (aka libdb2)
gnome-config links against libdb1, packaged programs are linked against libdb...
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-libs (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-26 09:18 EDT by Nils Philippsen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-01 03:37:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2000-07-26 09:18:38 EDT
When compiling a program that uses the GNOME libs, it gets linked against
libdb1, but
programs included in the official packages are linked against libdb
(libdb2). IMO gnome-libs
should be repackaged so that gnome-config uses libdb2 instead of libdb1.

Later,
Nils
Comment 1 Owen Taylor 2000-07-26 11:36:37 EDT
You had me worried with this bug problem, but I think the problem
is not there:

ldd /usr/bin/gnome_segv:

libdb.so.2 => /usr/lib/libdb.so.2 (0x4012b000)

ls -l  /usr/lib/libdb.so.2
/usr/lib/libdb.so.2 -> libdb1.so.2

Please reopen the bug if I am wrong.

We can't change what gnome-libs uses, because users have
~/.gnome/metadata.db in their home directory, and event
if we write a migration tool, we'd then be broken for
mixed 6.2, 7.0 installations at a single site.

Our decision on this, as I recall is to stick with db1
format until gnome2, which will be getting rid of 
metadata.db anyways.
Comment 2 Nils Philippsen 2000-07-26 13:04:29 EDT
I think I got misunderstood --

what I wanted to propose was that  the build of gnome-libs gets
changed in a way that programs compiled with some `gnome-config
--libs gnomeui` are linked in the same way as the packaged programs
(it looks like a discrepancy between the build system -- which links
against libdb -- and /usr/lib/gnomeConf.sh from gnome-libs-devel
which causes subsequent compilations to link against libdb1.

If anything is still unclear (or I'm just talking rubbish), please contact me.

Nils
Comment 3 Owen Taylor 2000-07-31 14:31:10 EDT
I still don't understand. gnome-config includes -ldb1.
The soname for -ldb1 is libdb.so.2.  This is the library that
the packaged programs are linked against. Thus, I assume they
were built against -ldb1...
Comment 4 Nils Philippsen 2000-08-01 03:37:30 EDT
I just checked it on a beta5 system and there
-ldb1 resolves to libdb.so.2 (as you said).

The problem occurred on an older beta, it
was probably triggered by something else --
I could think of a libdb1.so pointing to a
libdb1.so.xxx instead of libdb.so.2 -- which
obviously has been fixed in the meantime.

We found this as we packaged something
using the GNOME libs and it definitely
needed a libdb1.so to be installed instead
the GNOME stuff shipped with the beta
which needed libdb.so.

Thanks anyway!

Nils

Note You need to log in before you can comment on or make changes to this bug.