Bug 146614 - Inconsistent struct gconvcache_header
Summary: Inconsistent struct gconvcache_header
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-30 18:45 UTC by H.J. Lu
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version: 2.3.4-2.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-30 19:25:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description H.J. Lu 2005-01-30 18:45:28 UTC
When I was checking glibc from 2005-01-30's CVS on i686, I got

/export/build/gnu/glibc-nptl/build-i686-linux/iconv/gconv-
modules.cache.29517 /usr/lib/gconv/gconv-modules.cache differ: byte 
15, line 1
make[4]: *** [test-iconvconfig] Error 1

[hjl@gnu-10 glibc-nptl]$ rpm -qf /usr/lib/gconv/gconv-modules.cache
glibc-2.3.4-2

I have no problems on RHEL4/x86_64, RHEL3/x86_64 nor RHEL3/ia64.

Comment 2 H.J. Lu 2005-03-02 01:41:36 UTC
Here is the glibc bug report

http://sources.redhat.com/bugzilla/show_bug.cgi?id=776

Comment 3 Jakub Jelinek 2005-03-10 09:26:50 UTC
This is fixed in glibc-2.3.4-2.7.  Thanks.

Comment 4 Ulrich Drepper 2005-06-30 19:02:09 UTC
I'm closing this.  It's not really a RHEL issue since we don't support you
compiling glibc and using it with the system.

Comment 5 H.J. Lu 2005-06-30 19:08:26 UTC
I am not sure if I understand what you were trying to say. I did

# cvs co libc
...
# .../configure
# make
# make xcheck

and got the faulure on RHEL 4. Were you saying I shouldn't build glibc
on RHEL4? Do you have a stable Linux distribution you can recommend for
working on glibc?

Comment 6 Jakub Jelinek 2005-06-30 19:25:19 UTC
RHEL4 U1 included the fix.


Note You need to log in before you can comment on or make changes to this bug.