Bug 1466164 - office documents are not rendering because of missing dependencies from libreoffice
Summary: office documents are not rendering because of missing dependencies from libre...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreoffice
Version: 7.4
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: David Tardon
QA Contact: Desktop QE
Petr Bokoc
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1477211
TreeView+ depends on / blocked
 
Reported: 2017-06-29 08:07 UTC by Martin Krajnak
Modified: 2018-04-10 12:04 UTC (History)
6 users (show)

(edit)
*Gnome Documents* can not display some documents when installed without *LibreOffice* due to a missing dependency

*Gnome Documents* uses libraries provided by the *LibreOffice* suite for rendering certain types of documents, such as OpenDocument Text or Open Office XML formats. However, the required libraries (_libreoffice-filters_) are missing from the dependency list of the _gnome-documents_ package. Therefore, if you install *Gnome Documents* on a system that does not have *LibreOffice*, the aforementioned document types can not be rendered.

To work around this problem, install _libreoffice-filters_ package manually, even if you do not plan to use LibreOffice itself.
Clone Of:
(edit)
Last Closed: 2018-04-10 12:03:00 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0751 None None None 2018-04-10 12:04 UTC

Description Martin Krajnak 2017-06-29 08:07:52 UTC
Description of problem:
Gnome-documents is not able to render libreoffice, msoffice and OneDrive documents when installed on empty machine without libreoffice.

'yum -y install gnome documents' is installing the following packages:

Installing:
 gnome-documents                    x86_64       3.22.2-5.el7             
 libreoffice-langpack-en            x86_64       1:5.0.6.2-14.el7         

Installing for dependencies:
libreoffice-core                   x86_64       1:5.0.6.2-14.el7          libreoffice-opensymbol-fonts       noarch       1:5.0.6.2-14.el7        libreoffice-ure                    x86_64       1:5.0.6.2-14.el7        libreofficekit                     x86_64       1:5.0.6.2-14.el7   


Version-Release number of selected component (if applicable):
gnome-documents-3.22.2-5.el7.x86_64
libreofficekit-5.0.6.2-14.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.yum -y remove 'libreoffice*' (deletes also gnome-documents)
2.yum -y install gnome-documents
3.open documents and choose any libreoffice/mssoffice/OneDrive document

Actual results:
Documents is not rendered in some cases it crashes with following segmentation fault:
[10797.248754] gnome-documents[2226]: segfault at 0 ip 00007f38e04aac03 sp 00007ffd400d9f68 error 4 in libsfxlo.so[7f38e0307000+4ee000]

Expected results:
documents should be rendered without crash

Additional info:
the problem is solved by installing libreoffice:

yum -y install libreoffice

Comment 1 Martin Krajnak 2017-06-29 09:41:28 UTC
I cannot reproduce the segfault manually, only via automated test. I was able to retrieve the following backtrace from crash:

Program received signal SIGSEGV, Segmentation fault.
0x00007f1d4a4a0c03 in SfxViewShellArr_Impl::operator[](unsigned long) ()
   from /usr/lib64/libreoffice/program/libsfxlo.so
(gdb) backtrace
#0  0x00007f1d4a4a0c03 in SfxViewShellArr_Impl::operator[](unsigned long) ()
   from /usr/lib64/libreoffice/program/libsfxlo.so
#1  0x00007f1d4a705723 in SfxLokHelper::setView(unsigned long) ()
   from /usr/lib64/libreoffice/program/libsfxlo.so
#2  0x00007f1d74cfaee0 in doc_setView () from /usr/lib64/libreoffice/program/libsofficeapp.so
#3  0x00007f1d74f4a412 in postDocumentLoad(void*) () from /lib64/liblibreofficekitgtk.so
#4  0x00007f1d98ae2338 in gdk_threads_dispatch () from /lib64/libgdk-3.so.0
#5  0x00007f1d96cda0d7 in g_idle_dispatch () from /lib64/libglib-2.0.so.0
#6  0x00007f1d96cdd4c9 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#7  0x00007f1d96cdd818 in g_main_context_iterate.isra.21 () from /lib64/libglib-2.0.so.0
#8  0x00007f1d96cdd8cc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#9  0x00007f1d972957c5 in g_application_run () from /lib64/libgio-2.0.so.0
#10 0x00007f1d97b9ddcc in ffi_call_unix64 () from /lib64/libffi.so.6
#11 0x00007f1d97b9d6f5 in ffi_call () from /lib64/libffi.so.6
#12 0x00007f1d996b365e in ?? () from /lib64/libgjs.so.0
#13 0x00007f1d996b4b21 in ?? () from /lib64/libgjs.so.0
#14 0x00007f1d965c18f2 in js::Invoke(JSContext*, JS::CallArgs, js::MaybeConstruct) ()
   from /lib64/libmozjs-24.so
#15 0x00007f1d965c5731 in Interpret(JSContext*, js::RunState&) () from /lib64/libmozjs-24.so
#16 0x00007f1d965cf048 in js::RunScript(JSContext*, js::RunState&) () from /lib64/libmozjs-24.so
#17 0x00007f1d965cf274 in js::Execute(JSContext*, JS::Handle<JSScript*>, JSObject&, JS::Value*) ()
   from /lib64/libmozjs-24.so
#18 0x00007f1d9667c43b in JS::Evaluate(JSContext*, JS::Handle<JSObject*>, JS::CompileOptions, unsigned short const*, unsigned long, JS::Value*) () from /lib64/libmozjs-24.so
#19 0x00007f1d9667c59e in JS::Evaluate(JSContext*, JS::Handle<JSObject*>, JS::CompileOptions, char const*, unsigned long, JS::Value*) () from /lib64/libmozjs-24.so
#20 0x00007f1d996a6725 in gjs_eval_with_scope () from /lib64/libgjs.so.0
#21 0x00007f1d9969f373 in gjs_context_eval () from /lib64/libgjs.so.0
#22 0x00000000004012df in main ()
(gdb)

Comment 5 David Tardon 2017-06-29 11:29:36 UTC
Either libreofficekit or gnome-documents needs to add a dependency on libreoffice-filters, which will pull in all the necessary packages. It can be argued this should be in libreofficekit, as it is not very useful without it...

Comment 15 errata-xmlrpc 2018-04-10 12:03:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0751


Note You need to log in before you can comment on or make changes to this bug.