Bug 146618 - Using Disk Management cannot mount devices as normal user
Using Disk Management cannot mount devices as normal user
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-30 15:15 EST by Colleen Beamer
Modified: 2013-07-02 19:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 03:17:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colleen Beamer 2005-01-30 15:15:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Using 'Disk Management', I cannot mount my devices as a normal user. 
I have SELinux installed with the policy as "targeted".  According to
an article I read in Redhat magazine, my fstab file should allow a
normal user to mount devices since the line for the devices contains
'pamconsole' and 'managed'.

When I click on the 'Disk Management' when logged in under my normal
user id, I am told that there are no filesystems that I am allowed to
mount.

I can mount the devices as root from the command line.  I can also use
KDE's kwikdisk to mount devices as a normal user.  I should be able to
use "Disk Management" to mount my devices.

Version-Release number of selected component (if applicable):
usermode-gtk-1.74-1

How reproducible:
Always

Steps to Reproduce:
1.From the "System Tools" menu, click "Disk Management"
2.Error message displayed: "There are not filesytems which you are
allowed to mount or unmount.
3.Click OK to clear dialog
4.Remain frustrated that I cannot mount devices as a normal user using
"Disk Management"
    

Expected Results:  Using "Disk Management", I should be able to select
the device that I want to mount and have it mounted.  When finished
what I am doing, I should be able to unmount the device.

Additional info:
Comment 1 Colleen Beamer 2005-01-31 00:14:44 EST
This problem has been solved.  The solution was an upgrade to usermode
and usermode-gtk.  I have version 1.74 of these packages on my system.
 Neither Redhat Update Agent nor any yum repository flagged these
packages as needing to be upgraded.  However, I found a post that
stated that the solution was to upgrade to version 1.76.  rpmfind.net
had version 1.78 of these packages and I upgraded them and now I can
use Device Manager to mount my devices.
Comment 2 Jindrich Novy 2005-01-31 03:17:27 EST
Coleen, I've done some fixes related to this issue in usermode. The
problem was mainly in misunderstandings between hal and usermount. The
version 1.76-1 contains a fix for this.

Thanks for your report,
Jindrich

Note You need to log in before you can comment on or make changes to this bug.