Bug 14662 - GCC 2.96 -fpermssive flag broken
GCC 2.96 -fpermssive flag broken
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-26 09:19 EDT by Suhaib Siddiqi
Modified: 2007-04-18 12:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 17:33:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suhaib Siddiqi 2000-07-26 09:19:21 EDT
In Beta-4 Gcc 2.96 -fpermissibe flag seems to be broken.  When compiling a 
code which is not ANSI complaint, using -fpermissive flag makes no 
difference.  Although, if I use GCC 2.95.2 with -fpermissive flag
the same code compiles.  Therefore, I assume -fpermissive flag to downgrade
gcc 2.96 performance to compile source code which is not strictly ANSI
complaint, is broken.

Suhaib
Comment 1 Richard Henderson 2004-10-01 17:33:24 EDT
No test case, and PR is over 4 years old, so I don't believe that
NEEDINFO is helpful.

Note You need to log in before you can comment on or make changes to this bug.