Bug 1466238 - On Qemu/KVM – An error message with an unknown reference in quote.
On Qemu/KVM – An error message with an unknown reference in quote.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 06:19 EDT by ricky.tigg
Modified: 2017-07-10 19:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-10 19:58:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unknown reference in quote. (6.48 KB, image/png)
2017-06-29 06:19 EDT, ricky.tigg
no flags Details

  None (edit)
Description ricky.tigg 2017-06-29 06:19:59 EDT
Created attachment 1292837 [details]
Unknown reference in quote.

Description of problem:
On Qemu/KVM, when the option Disk device is selected as Device type, the only available options as Bus type are IDE, SCSI, USB, VirtIO, but not such a thing as “hd” (see attachment). By the way a mixed language is noticeable and may be eligible for a bug report for the Localization Finnish team.

Version-Release number of selected component (if applicable):
1.4.1-2.fc25

How reproducible:
Steps to Reproduce:
1. Applying to any virtual machine, for a test case, attempt to add a fourth disk with an IDE bus type to already existing disks whose bus are the same type (Show virtual hardware details --> Add hardware --> Storage).

Actual results:
in error message there is an unknown reference in quote while attempting to add a fourth disk with IDE bus type.

Expected results:
Just something in quote that makes sense for users.
Comment 1 Cole Robinson 2017-07-10 19:58:57 EDT
Thanks for the report. 'hd' in this case refers to the device name hda/hdb/... we are trying to generate for an IDE device, so it's really saying 'cant have more than 4 ide devices'. You mention you already have 3 IDE devices but maybe a 4th one is a CDROM, so attempting to add another one is hitting the limit.

Anyways, I improved the message upstream now:

devicedisk: Improve error message when max IDE devs exceeded (bz 1466238)

https://bugzilla.redhat.com/show_bug.cgi?id=1466238


Just closing as UPSTREAM since this isn't critical enough to backport

Note You need to log in before you can comment on or make changes to this bug.