Bug 146627 - dovecot FC3 has lower Release: than in FC2
dovecot FC3 has lower Release: than in FC2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-30 21:48 EST by Jeff Moe (jebba)
Modified: 2014-01-21 17:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-31 11:07:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Moe (jebba) 2005-01-30 21:48:11 EST
Description of problem:
The Release: number in dovecot is lower in FC3 than the FC2 errata.
This is true of the recently pushed fc3 dovecot update as well.

Version-Release number of selected component (if applicable):
FC2 Update: dovecot-0.99.13-4.FC2.i386.rpm
FC3 Update: dovecot-0.99.13-3.FC3.i386.rpm

If the Release: number was more like:
dovecot-0.99.13-FC2.4.i386.rpm
dovecot-0.99.13-FC3.3.i386.rpm
this type of issue could be avoided...
Comment 1 John Dennis 2005-01-31 11:07:59 EST
Comparing rpm's between distributions is not supported. FC2 and FC3
are two independent distributions. Within their own distribution the
rpm's colate correctly. 

As a side note, your suggestion of prepending the distribution in the
release field as opposed to appending it only works in in a subset of
cases and is not a general solution. Why? Because if the distribution
component, e.g. FCn were anything other than FCn it may not sort
correctly, this is just one of several reasons why you can't compare
rpms between distributions)

Another reason why its a bad idea to compare rpm between distributions
is the dependency issue with other components, and finally different
distributions can organize files and directories differently mean you
may have installation or configuration errors.

Note You need to log in before you can comment on or make changes to this bug.