Bug 1466270 - Incorrect response format (not XML) for REST call on VM creation.
Incorrect response format (not XML) for REST call on VM creation.
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RestAPI (Show other bugs)
4.1.3.4
x86_64 All
unspecified Severity medium (vote)
: ovirt-4.2.0
: 4.2.0
Assigned To: Ori Liel
Radim Hrazdil
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 07:35 EDT by Vitalii Yerys
Modified: 2017-12-20 06:02 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:02:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 81212 master POST Improve Message Format For Invlaid Id Input 2017-08-30 09:11 EDT

  None (edit)
Description Vitalii Yerys 2017-06-29 07:35:26 EDT
Description of problem:

If VM created with incorrect ID format, response is returned as a string format instead of XML which would be expected.

Version-Release number of selected component (if applicable):

Red Hat Virtualization Manager Version: 4.1.3.4-0.1.el7

How reproducible:

100%

Steps to Reproduce:
1. try creating VM via REST with following request:

POST
<vm id="11111">
    <name>test_vm_name</name>
    <description>test_vm_description</description>
    <display>
        <type>spice</type>
    </display>
    <os>
        <type>rhel_7x64</type>
...
</vm>

Full example here:

http://pastebin.test.redhat.com/498840

Actual results:

Invalid UUID string: 11111

Expected results:

<fault>
    <detail>[Invalid UUID string: 11111.]</detail>
    <reason>Operation Failed</reason>
</fault>

Additional info:
Comment 1 Tomas Jelinek 2017-06-30 03:40:37 EDT
This happens on all collections I have tried (vms, clusters, permissions...).

Seems like an infra issue/decision. Moving to infra to decide.
Comment 2 Juan Hernández 2017-06-30 05:27:17 EDT
I agree this should be improved. Ori, can you take a look?
Comment 3 Red Hat Bugzilla Rules Engine 2017-06-30 05:27:22 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 4 Ori Liel 2017-08-30 08:55:05 EDT
Patch posted: 

  https://gerrit.ovirt.org/#/c/81212
Comment 5 Radim Hrazdil 2017-09-06 03:33:08 EDT
Verified in 4.2.0-0.0.master.20170903205106.gitb17261a.el7.centos
Comment 6 Sandro Bonazzola 2017-12-20 06:02:59 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.