Bug 1466334 - virsh domdisplay not working with listen type=socket
virsh domdisplay not working with listen type=socket
Status: CLOSED DUPLICATE of bug 1336720
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Depends On:
  Show dependency treegraph
Reported: 2017-06-29 08:54 EDT by Christophe Fergeau
Modified: 2017-06-29 09:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-06-29 09:10:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christophe Fergeau 2017-06-29 08:54:52 EDT
I have
    <graphics type='spice'>
      <listen type='socket' socket='/tmp/foo'/>
set for one of my VMs, and virsh domdisplay tells me
error :No graphical display found

I'd expect to get something like spice+unix:///tmp/foo in this case.
The same error is reported with listen type='none' but I'm not sure if something could be reported in this case (No graphical display is not correct though, so error message might need improving).
Comment 1 Christophe Fergeau 2017-06-29 09:10:03 EDT
Haha sorry I ialready filed that a long time ago and forgot :)

*** This bug has been marked as a duplicate of bug 1336720 ***

Note You need to log in before you can comment on or make changes to this bug.