Bug 1466356 - Serial console output is garbled in U-Boot on Raspberry Pi
Serial console output is garbled in U-Boot on Raspberry Pi
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bcm283x-firmware (Show other bugs)
26
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
AcceptedFreezeException
:
Depends On:
Blocks: ARMTracker F26FinalFreezeException
  Show dependency treegraph
 
Reported: 2017-06-29 09:27 EDT by Paul Whalen
Modified: 2017-07-06 18:52 EDT (History)
7 users (show)

See Also:
Fixed In Version: bcm283x-firmware-20170613-2.73f44c6.fc26
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-06 18:52:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2017-06-29 09:27:50 EDT
Description of problem:
Serial console output is garbled in U-Boot on Raspberry Pi, the system boots ok but no output is shown while in uboot.

Version-Release number of selected component (if applicable):
uboot-images-armv7-2017.05-4.fc26

Actual results:


...
Kernel not configured for semaphores (System V IPC). Not using udev synchronisation code.
Kernel not configured for semaphores (System V IPC). Not using udev synchronisation code.
Rebooting.
[59393.793808] reboot: Restarting system
��������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������������0
[    0.000000] Linux version 4.11.7-300.fc26.armv7hl+lpae (mockbuild@buildvm-armv7-16.arm.fedoraproject.org) (gcc version 7.1.1 20170622 (Red Hat 7.1.1-3) (GCC) ) #1 SMP Mon Jun 26 14:46:41 UTC 2017
[    0.000000] CPU: ARMv7 Processor [410fd034] revision 4 (ARMv7), cr=30c5383d
[    0.000000] CPU: div instructions available: patching division code
[    0.000000] CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
[    0.000000] OF: fdt: Machine model: Raspberry Pi 3 Model B
....

Expected results:
Output in U-Boot
Comment 1 Peter Robinson 2017-07-01 11:28:24 EDT
Issue with firmware, reported upstream https://github.com/raspberrypi/firmware/issues/833
Comment 2 Fedora Blocker Bugs Application 2017-07-03 09:09:13 EDT
Proposed as a Freeze Exception for 26-final by Fedora user pbrobinson using the blocker tracking app because:

 This is a regression on the Serial Console of the Raspberry Pi. I'm filing this as a freeze exception as the HDMI display output works as expected, but the serial console is a common use case and is useful for a number of use cases so it's useful to have this fixed for a decent OOTB experience for a primary ARM device.
Comment 3 Fedora Update System 2017-07-03 09:10:12 EDT
bcm283x-firmware-20170613-2.73f44c6.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8778f518d6
Comment 4 Matthew Miller 2017-07-03 10:49:28 EDT
+1 FE. Pi support is a big deal.
Comment 5 Fedora Update System 2017-07-03 14:25:40 EDT
bcm283x-firmware-20170613-2.73f44c6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8778f518d6
Comment 6 Adam Williamson 2017-07-03 14:40:20 EDT
Discussed at 2017-07-03 freeze exception review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-07-03/f26-blocker-review.2017-07-03-16.06.html . Accepted as a freeze exception issue, as obviously Pi is one of our major target platforms and it's important to try and ensure serial console output works. Also the change seems quite safe (reversion to a previously-tested version).
Comment 7 Fedora Update System 2017-07-06 18:52:29 EDT
bcm283x-firmware-20170613-2.73f44c6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.