Bug 1466419 - RFE: Use SRV Records (for AD/IPA) to determine best server for AD
RFE: Use SRV Records (for AD/IPA) to determine best server for AD
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Weil
Xiaoli Tian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 10:26 EDT by Marc Nozell
Modified: 2017-10-18 09:48 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-18 09:48:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Nozell 2017-06-29 10:26:31 EDT
1. Proposed title of this feature request

RFE: Use SRV Records (for AD/IPA) to determine best server for AD 

3. What is the nature and description of the request?

Want to be able to have multiple LDAP servers

4. Why does the customer need this? (List the business requirements here)

To support multiple LDAP servers.

If KRB5 is supported, this RFE is no longer required since it supports
SRV records to use multiple LDAP servers.

5. How would the customer like to achieve this? (List the functional requirements here)

6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.

7. Is there already an existing RFE upstream or in Red Hat Bugzilla?

No

10. List any affected packages or components.
Comment 2 Jordan Liggitt 2017-07-01 18:31:02 EDT
krb5 and multiple LDAP server support can both be accomplished by using a request header authentication provider.

The external LDAP authentication setup is described in 


https://docs.openshift.com/container-platform/3.5/install_config/configuring_authentication.html#RequestHeaderIdentityProvider

https://docs.openshift.com/container-platform/3.5/install_config/advanced_ldap_configuration/index.html
Comment 3 Paul Weil 2017-10-18 09:48:15 EDT
Closing this since solution has been proposed and no further feedback has been given.  Please reopen if necessary

Note You need to log in before you can comment on or make changes to this bug.