Bug 1466423 - cockpit broken after latest updates
cockpit broken after latest updates
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cockpit (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dominik Perpeet
qe-baseos-daemons
: Extras, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 10:31 EDT by Marko Myllynen
Modified: 2017-07-04 12:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: cockpit-141-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-04 05:39:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2017-06-29 10:31:52 EDT
Description of problem:
After updates released on 2017-06-28 we see now the following packages being available:

cockpit-bridge-138-6.el7.x86_64
cockpit-dashboard-141-1.el7.x86_64
cockpit-docker-141-1.el7.x86_64
cockpit-kubernetes-141-1.el7.x86_64
cockpit-pcp-141-1.el7.x86_64
cockpit-system-138-6.el7.noarch
cockpit-ws-138-6.el7.x86_64

The version mismatch prevent e.g. the dashboard opening.
Comment 3 Dominik Perpeet 2017-06-29 11:32:58 EDT
(In reply to Marko Myllynen from comment #0)
> Description of problem:
> After updates released on 2017-06-28 we see now the following packages being
> available:
> 
> cockpit-bridge-138-6.el7.x86_64
> cockpit-dashboard-141-1.el7.x86_64
> cockpit-docker-141-1.el7.x86_64
> cockpit-kubernetes-141-1.el7.x86_64
> cockpit-pcp-141-1.el7.x86_64
> cockpit-system-138-6.el7.noarch
> cockpit-ws-138-6.el7.x86_64
> 
> The version mismatch prevent e.g. the dashboard opening.

I can confirm this is happening and I see the cause - there's a wrong manifest.json dependency in the dashboard, ssh is also affected.
Comment 5 Dominik Perpeet 2017-06-29 11:42:16 EDT
Workaround:

Edit the manifest.json files in /usr/share/cockpit:

/usr/share/cockpit/dashboard/manifest.json
-	"cockpit": "138.x"
+	"cockpit": "138"

and the same for /usr/share/cockpit/ssh/manifest.json
Comment 7 Marko Myllynen 2017-06-29 11:52:13 EDT
(In reply to Dominik Perpeet from comment #5)
> Workaround:
> 
> Edit the manifest.json files in /usr/share/cockpit:
> 
> /usr/share/cockpit/dashboard/manifest.json
> -	"cockpit": "138.x"
> +	"cockpit": "138"
> 
> and the same for /usr/share/cockpit/ssh/manifest.json

Confirmed, this can be used to workaround the issue, thanks!
Comment 13 errata-xmlrpc 2017-07-04 05:39:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1673

Note You need to log in before you can comment on or make changes to this bug.