Bug 1466620 - logging services were not deleted after undeploying logging via ansible
logging services were not deleted after undeploying logging via ansible
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging (Show other bugs)
3.6.0
Unspecified Unspecified
low Severity low
: ---
: 3.6.z
Assigned To: Jeff Cantrill
Junqi Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 01:21 EDT by Junqi Zhao
Modified: 2017-10-25 09:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-25 09:02:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Junqi Zhao 2017-06-30 01:21:30 EDT
Description of problem:
Undeploy logging 3.6.0, logging services were not deleted

Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-filter-plugins-3.6.126.4-1.git.0.d25d828.el7.noarch
openshift-ansible-playbooks-3.6.126.4-1.git.0.d25d828.el7.noarch
openshift-ansible-docs-3.6.126.4-1.git.0.d25d828.el7.noarch
openshift-ansible-lookup-plugins-3.6.126.4-1.git.0.d25d828.el7.noarch
openshift-ansible-roles-3.6.126.4-1.git.0.d25d828.el7.noarch
openshift-ansible-3.6.126.4-1.git.0.d25d828.el7.noarch
openshift-ansible-callback-plugins-3.6.126.4-1.git.0.d25d828.el7.noarch

Images from ops mirror
logging-elasticsearch            v3.6.126.4-1        7969b6dcb11e        4 hours ago         404.2 MB
logging-kibana                   v3.6.126.4-1        5349edde24e5        4 hours ago         342.4 MB
logging-auth-proxy               v3.6.126.4-1        373f69a74465        4 hours ago         214.8 MB
logging-fluentd                  v3.6.126.4-1        218c2e3246e4        4 hours ago         232.5 MB
logging-curator                  3.6.99-3            757cf4948069        2 days ago          221.5 MB

How reproducible:
Always

Steps to Reproduce:
1. Undeploy logging 3.6.0.
2. Run command "oc get svc".
3.

Actual results:
logging services were not deleted
# oc get svc
NAME                 CLUSTER-IP       EXTERNAL-IP   PORT(S)    AGE
logging-es           172.30.171.149   <none>        9200/TCP   50m
logging-es-cluster   172.30.12.114    <none>        9300/TCP   50m
logging-kibana       172.30.216.175   <none>        443/TCP    50m


Expected results:
logging services should be deleted

Additional info:
Inventory file:

[OSEv3:children]
masters

[masters]
${MASTER} openshift_public_hostname=${MASTER}

[OSEv3:vars]
ansible_ssh_user=root
ansible_ssh_private_key_file="~/libra.pem"
deployment_type=openshift-enterprise

# Logging
openshift_logging_install_logging=false
openshift_logging_kibana_hostname=kibana.${SUB_DOMAIN}
openshift_logging_kibana_ops_hostname=kibana-ops.${SUB_DOMAIN}
public_master_url=https://${MASTER}:${PORT}
openshift_logging_image_prefix=${IMAGE_PREFIX}
openshift_logging_image_version=v3.6
openshift_logging_namespace=logging
Comment 1 Noriko Hosoi 2017-07-20 20:00:56 EDT
@Janqi, Sorry for my ignorance...  Could you put the command line(s?) for this step?
1. Undeploy logging 3.6.0.
Thanks!
Comment 2 Junqi Zhao 2017-07-20 20:50:34 EDT
(In reply to Noriko Hosoi from comment #1)
> @Janqi, Sorry for my ignorance...  Could you put the command line(s?) for
> this step?
> 1. Undeploy logging 3.6.0.
> Thanks!

Use the inventory file in Comment 0 to undeploy logging, openshift_logging_install_logging=false means to undeploy logging

# cd /usr/share/ansible/openshift-ansible/
# ansible-playbook -vvv -i ${INVENTORY_FILE}   playbooks/byo/openshift-cluster/openshift-logging.yml
Comment 3 Jeff Cantrill 2017-08-25 16:41:12 EDT
Using code from HEAD on master of openshift-ansible unable to reproduce.
Comment 4 Junqi Zhao 2017-08-27 21:28:47 EDT
Issue is fixed,  logging services are deleted after undeploying logging via ansible.

Testing environment:
# openshift version
openshift v3.6.173.0.19
kubernetes v1.6.1+5115d708d7
etcd 3.2.1

Logging images:
logging-kibana:v3.6.173.0.19-1
logging-elasticsearch:v3.6.173.0.19-1
logging-fluentd:v3.6.173.0.19-1
logging-auth-proxy:v3.6.173.0.19-1
logging-curator:v3.6.173.0.19-1
Comment 6 errata-xmlrpc 2017-10-25 09:02:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3049

Note You need to log in before you can comment on or make changes to this bug.