Bug 1466622 - docker_image_availability check on etcd host failed for 'openshift_image_tag' is undefined
docker_image_availability check on etcd host failed for 'openshift_image_tag'...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
Gaoyun Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 01:32 EDT by Gaoyun Pei
Modified: 2017-08-16 15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-20 10:06:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2017-06-30 01:32:39 EDT
Description of problem:
Start a containerized installation on Atomic Host, it failed when running openshift_health_check on etcd host.

TASK [openshift_health_check] **************************************************
Friday 30 June 2017  02:34:40 +0000 (0:00:00.073)       0:02:34.132 *********** 

CHECK [docker_storage : qe-gpei-etcd-sc-etcd-1.0630-y18.qe.rhcloud.com] ********

CHECK [docker_storage : qe-gpei-etcd-sc-master-1.0630-y18.qe.rhcloud.com] ******

CHECK [docker_storage : qe-gpei-etcd-sc-node-registry-router-1.0630-y18.qe.rhcloud.com] ***

CHECK [disk_availability : qe-gpei-etcd-sc-etcd-1.0630-y18.qe.rhcloud.com] *****

CHECK [package_availability : qe-gpei-etcd-sc-etcd-1.0630-y18.qe.rhcloud.com] **

CHECK [package_version : qe-gpei-etcd-sc-etcd-1.0630-y18.qe.rhcloud.com] *******

CHECK [docker_image_availability : qe-gpei-etcd-sc-etcd-1.0630-y18.qe.rhcloud.com] ***

CHECK [memory_availability : qe-gpei-etcd-sc-etcd-1.0630-y18.qe.rhcloud.com] ***

CHECK [memory_availability : qe-gpei-etcd-sc-etcd-1.0630-y18.qe.rhcloud.com] ***
fatal: [qe-gpei-etcd-sc-etcd-1.0630-y18.qe.rhcloud.com]: FAILED! => {
    "changed": false, 
    "checks": {
        "disk_availability": {
            "skipped": true, 
            "skipped_reason": "Not active for this host"
        }, 
        "docker_image_availability": {
            "failed": true, 
            "msg": "'openshift_image_tag' is undefined"
        }, 
        "docker_storage": {
            "changed": false, 
            "data_pct_used": 0.09521842878120412, 
            "data_threshold": 90.0, 
            "data_total": "11.43 GB", 
            "data_total_bytes": 12272869048.32, 
            "data_used": "19.92 MB", 
            "data_used_bytes": 20887633.92, 
            "metadata_pct_used": 0.00047574104956457343, 
            "metadata_threshold": 90.0, 
            "metadata_total": "33.55 MB", 
            "metadata_total_bytes": 35179724.8, 
            "metadata_used": "45.06 kB", 
            "metadata_used_bytes": 46141.44, 
            "msg": "Thinpool usage is within thresholds.", 
            "vg_free": "9.00g", 
            "vg_free_bytes": 9663676416.0
        }, 
        "memory_availability": {}, 
        "package_availability": {
            "skipped": true, 
            "skipped_reason": "Not active for this host"
        }, 
        "package_version": {
            "skipped": true, 
            "skipped_reason": "Not active for this host"
        }
    }, 
    "failed": true, 
    "playbook_context": "install"
}

MSG:

One or more checks failed



Version-Release number of selected component (if applicable):
openshift-ansible-3.6.126.4-1.git.0.d25d828.el7.noarch.rpm

How reproducible:
Always

Steps to Reproduce:
1.Run a containerized installation on Atomic Host with openshift_release=v3.6 set in ansible inventory

Actual results:


Expected results:


Additional info:
Comment 2 Luke Meyer 2017-06-30 09:49:50 EDT
Interesting that `openshift_version` doesn't fail or figure this out for an etcd-only containerized host.

The check doesn't actually need the image tag in that specific case, since the only image needed is etcd and that is essentially unversioned (just gets latest). I'll look at the code to see if there's any concern somewhere else with just defaulting to :latest as the tag.
Comment 4 openshift-github-bot 2017-06-30 19:05:17 EDT
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/4d3574957508c257e12d9ba8ec8de48ed9789eb9
docker_image_availability: fix containerized etcd

fixes bug 1466622 - docker_image_availability check on etcd host failed for 'openshift_image_tag' is undefined
Comment 6 Gaoyun Pei 2017-07-04 03:46:30 EDT
Verify this bug with openshift-ansible-3.6.132-1.git.0.0d0f54a.el7.noarch.rpm

For containerized installation, docker_image_availability check on etcd host passed.

ok: [qe-gpei-etcd-sc-etcd-1.0704-iok.qe.rhcloud.com] => {
    "changed": false, 
    "checks": {
        "disk_availability": {}, 
        "docker_image_availability": {
            "changed": false
        }, 
        "docker_storage": {
            "changed": false, 
            "data_pct_used": 0.09521842878120412, 
            "data_threshold": 90.0, 
            "data_total": "11.43 GB", 
            "data_total_bytes": 12272869048.32, 
            "data_used": "19.92 MB", 
            "data_used_bytes": 20887633.92, 
            "metadata_pct_used": 0.00047574104956457343, 
            "metadata_threshold": 90.0, 
            "metadata_total": "33.55 MB", 
            "metadata_total_bytes": 35179724.8, 
            "metadata_used": "45.06 kB", 
            "metadata_used_bytes": 46141.44, 
            "msg": "Thinpool usage is within thresholds.", 
            "vg_free": "9.00g", 
            "vg_free_bytes": 9663676416.0
        }, 
        "memory_availability": {}, 
        "package_availability": {
            "skipped": true, 
            "skipped_reason": "Not active for this host"
        }, 
        "package_version": {
            "skipped": true, 
            "skipped_reason": "Not active for this host"
        }
    }, 
    "playbook_context": "install"
}
Comment 7 Luke Meyer 2017-07-20 10:06:47 EDT
never released

Note You need to log in before you can comment on or make changes to this bug.