Bug 1466649 - [DNF] rpm.RPMCALLBACK_ELEM_PROGRESS does not exist
Summary: [DNF] rpm.RPMCALLBACK_ELEM_PROGRESS does not exist
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rpm   
(Show other bugs)
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: pre-dev-freeze
: ---
Assignee: Igor Gnatenko
QA Contact: Jan Blazek
URL:
Whiteboard:
Keywords:
: 1466768 (view as bug list)
Depends On:
Blocks: 1465896 1466368 1461652
TreeView+ depends on / blocked
 
Reported: 2017-06-30 07:19 UTC by Daniel Mach
Modified: 2018-04-10 15:59 UTC (History)
6 users (show)

Fixed In Version: rpm-4.11.3-27.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 15:58:38 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0877 None None None 2018-04-10 15:59 UTC

Description Daniel Mach 2017-06-30 07:19:32 UTC
This currently blocks DNF running on RHEL 7.
The feature has to be either backported into RPM (preferred) or we need to find a workaround in the DNF code.

  File "/usr/lib/python2.7/site-packages/dnf/yum/rpmtrans.py", line 425, in callback
    elif what == rpm.RPMCALLBACK_ELEM_PROGRESS:
AttributeError: 'module' object has no attribute 'RPMCALLBACK_ELEM_PROGRESS'

Comment 1 Panu Matilainen 2017-06-30 07:40:41 UTC
This should be fairly trivial to backport.

Comment 2 Panu Matilainen 2017-06-30 07:42:53 UTC
For reference, the relevant upstream commits are:
448db68ceb5be3c7171b7ec0ea908d905792dc2f
124ed29259b05fdf574d5e3e145bc1201b24ae4d

Comment 3 Panu Matilainen 2017-06-30 12:23:30 UTC
*** Bug 1466768 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2018-04-10 15:58:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0877


Note You need to log in before you can comment on or make changes to this bug.