Bug 1466664 - oc patch dc reports dc changed even if no changes made
oc patch dc reports dc changed even if no changes made
Status: CLOSED DUPLICATE of bug 1466671
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Derek Carr
DeShuai Ma
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 04:04 EDT by Marko Myllynen
Modified: 2017-07-02 04:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-30 14:07:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marko Myllynen 2017-06-30 04:04:35 EDT
Description of problem:
When running something like

oc patch dc registry-console -p '{"spec":{"template":{"spec":{"nodeSelector":{"role":"infra"}}}}}'

several times in a row, oc always informs '"registry-console" patched' even though no changes were made.
Comment 1 Xingxing Xia 2017-06-30 06:49:05 EDT
Please check if patched field's name/level is correct, seems it should be "selector" rather than "nodeSelector"
See https://bugzilla.redhat.com/show_bug.cgi?id=1409225#c3
Comment 2 Fabiano Franz 2017-06-30 14:07:23 EDT

*** This bug has been marked as a duplicate of bug 1466671 ***

Note You need to log in before you can comment on or make changes to this bug.