Bug 1466666 - ctrl+f stopped working in qupzilla
Summary: ctrl+f stopped working in qupzilla
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qt5-qtwebengine
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-30 08:06 UTC by Karel Volný
Modified: 2017-11-27 15:08 UTC (History)
4 users (show)

Fixed In Version: qt5-qtwebengine-5.9.2-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-27 15:08:48 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-61621 None None None 2017-11-27 15:08:48 UTC

Description Karel Volný 2017-06-30 08:06:03 UTC
Description of problem:
After recent update of qt5-qtwebengine, the keyboard shortcut "ctrl+f" to find text within page has stopped working.

Version-Release number of selected component (if applicable):
qt5-qtwebengine-5.9.0-4.fc26

How reproducible:
always

Steps to Reproduce:
1. run qupzilla
2. open some webpage
3. hit 'ctrl+f'

Actual results:
nothing happens

Expected results:
a text search field opens at the bottom of window where you can enter a string you want to find within the page

Additional info:
The searching itself works if invoked from menu.
Other keyboard shortcuts like ctrl+t, ctrl+w, ctrl+q ... work as expected.

Comment 1 Christian Dersch 2017-06-30 08:09:17 UTC
Cannot reproduce, ctrl+f works as expected here. Same qtwebengine version and latest qupzilla in f26.

Comment 2 Karel Volný 2017-06-30 08:56:50 UTC
https://bodhi.fedoraproject.org/updates/qt5-qtwebengine-5.9.0-4.fc26#comment-629306

> What I know is that Ctrl+f is not working right in plain text files even with
> QtWebEngine 5.8.0. So I don't think that that is a regression from this update.

with previous version, I've experienced some issues that

a) happened randomly
b) could be fixed by clicking somewhere within the webpage then retrying the shortcut

so I suspected some strange focus stealing

however, after the update, it is different - it happens for 100% and clicking into page doesn't help

just tell me what would be useful to know - should I strace something etc.?

... btw, I use LXQt if that matters (yes, I do have some other shortcut-related issues like printscreen not invoking lximage-qt)

Comment 3 Kevin Kofler 2017-11-16 12:01:32 UTC
Can you please test whether qt5-qtwebengine-5.9.2-2.fc26 (now queued for testing) fixes this?
https://bodhi.fedoraproject.org/updates/FEDORA-2017-9a7e562fca

QtWebEngine 5.9.2 should fix https://bugreports.qt.io/browse/QTBUG-61621 , which might be the cause of this issue.

Comment 4 Kevin Kofler 2017-11-27 15:08:48 UTC
As far as I can tell, this is indeed fixed in 5.9.2: I am running qt5-qtwebengine-5.9.2-2.fc25 now, and Ctrl+F works for me now (I don't have to click into the location bar to make it work anymore). I am therefore closing this bug, please reopen it if the issue persists.


Note You need to log in before you can comment on or make changes to this bug.