Bug 146667 - RH-Bugzilla version does not differ from main stream bugzilla
RH-Bugzilla version does not differ from main stream bugzilla
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
Mike MacKenzie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-31 12:19 EST by Jeff Pound
Modified: 2007-03-27 00:26 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.18-rh
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-13 10:53:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Pound 2005-01-31 12:19:11 EST
Description of problem:
The rh-bugzilla uses the same version identifiers as the main stream
bugzilla. This makes machine processing of bugs difficult because
there isnt a way of determining the type of bugzilla install (RH or
main stream).

Heres an example:
https://bugzilla.redhat.com/bugzilla/xml.cgi?id=1

notice the version is "2.17.1"

Steps to Reproduce:
1. View a bug and look at the version
  
Actual results:
The version identifier doesnt differ from main stream bugzilla.

Expected results:
The version should identify this as a Red Hat Bugzilla system (for
example: "2.17.1-rh".
Comment 1 David Lawrence 2005-08-24 12:52:44 EDT
Moving to 2.18 since same problem there. Will change the version to be more rh
specific.
Comment 2 Bug Testing 2006-01-13 10:43:57 EST
Any news on this, Dave?  We're looking at making the Eclipse bugzilla plugin use
XML-RPC for RH bugzilla but we can't do that until we can differentiate between
RH and another bugzilla installation.

Thanks.
Comment 3 David Lawrence 2006-01-13 10:53:13 EST
Sorry for the delay on this. It fell off my radar due to other things. I have
changed it to 2.18-rh.

Dave
Comment 4 Andrew Overholt 2006-01-13 11:00:26 EST
Thanks very much!

Note You need to log in before you can comment on or make changes to this bug.