Bug 1466680 - [trello nEOGoTet] Elasticsearch is always deployed to -n logging, regardless of ${openshift_logging_namespace} in inventory
[trello nEOGoTet] Elasticsearch is always deployed to -n logging, regardless ...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jeff Cantrill
Xia Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 04:50 EDT by Xia Zhao
Modified: 2017-08-16 15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
inventory file used for logging deployment to let this bz repro (670 bytes, text/plain)
2017-06-30 04:53 EDT, Xia Zhao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Github openshift/openshift-ansible/pull/4656 None None None 2017-06-30 10:54 EDT

  None (edit)
Description Xia Zhao 2017-06-30 04:50:32 EDT
Description of problem:
set openshift_logging_namespace=logging2 in inventory file, the es pod is still deployed to -n logging: 
logging        logging-es-data-master-t4z30nt2-1-sczc4   1/1       Running     0          5m
logging2       logging-curator-1-3rssj                   0/1       Error       3          5m
logging2       logging-fluentd-kgxks                     1/1       Running     0          4m
logging2       logging-fluentd-qwbfs                     1/1       Running     0          4m
logging2       logging-kibana-1-lpvgd                    2/2       Running     0          5m


Version-Release number of selected component (if applicable):
openshift-ansible-playbooks-3.6.126.4-1.git.0.d25d828.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging with the attached inventory file

Actual results:
es is still deployed to -n logging, not the namespace specified in ${openshift_logging_namespace}

Expected results:
es should be deployed into -n ${openshift_logging_namespace}

Additional info:
Comment 1 Xia Zhao 2017-06-30 04:53 EDT
Created attachment 1293153 [details]
inventory file used for logging deployment to let this bz repro
Comment 2 Jeff Cantrill 2017-06-30 10:00:10 EDT
Setting to 3.6.1 as I dont see this really as a blocker
Comment 5 Xia Zhao 2017-07-06 01:40:42 EDT
It's fixed, verified with 
openshift-ansible-playbooks-3.6.135-1.git.0.5533fe3.el7.noarch

all logging stacks can be deployed to namespace other than "logging":
# oc project xiazhao
Now using project "xiazhao" on server "https://host-8-175-189.host.centralci.eng.rdu2.redhat.com:8443".
# oc get po
NAME                                      READY     STATUS    RESTARTS   AGE
logging-curator-1-lv9q0                   1/1       Running   0          2m
logging-es-data-master-0q37jjq2-1-ct6s4   1/1       Running   0          2m
logging-fluentd-gxdn9                     1/1       Running   0          2m
logging-fluentd-zq421                     1/1       Running   0          2m
logging-kibana-1-fsb04                    2/2       Running   0          2m
Comment 7 errata-xmlrpc 2017-08-10 01:29:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.