Bug 1466703 - [trello nEOGoTet] Not able to deploy logging with dynamic pv + ops cluster enabled
[trello nEOGoTet] Not able to deploy logging with dynamic pv + ops cluster en...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: ewolinet
Xia Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 05:43 EDT by Xia Zhao
Modified: 2017-08-16 15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
This bug was introduced with refactoring changes made for 3.6; fixing it prevents a regression.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the inventory file when dynamic pv + ops cluster enabled --> the failed deployment (969 bytes, text/plain)
2017-06-30 05:43 EDT, Xia Zhao
no flags Details
ansible execution log (508.71 KB, text/plain)
2017-06-30 05:57 EDT, Xia Zhao
no flags Details
the inventory file when dynamic pv + ops cluster disabled --> the succeeded deployment (972 bytes, text/plain)
2017-06-30 05:57 EDT, Xia Zhao
no flags Details

  None (edit)
Description Xia Zhao 2017-06-30 05:43:55 EDT
Created attachment 1293172 [details]
the inventory file when dynamic pv + ops cluster enabled --> the failed deployment

Description of problem:
Not able to deploy logging with dynamic pv + ops cluster enabled, meet this error: 

MSG:
{u'returncode': 1, u'cmd': u'/usr/bin/oc replace -f /tmp/openshift-logging-ansible-aLJDxB/templates/logging-es-pvc.yml -n logging', u'results': {}, u'stderr': u'The PersistentVolumeClaim "logging-es-0" is invalid: spec: Forbidden: field is immutable after creation\n', u'stdout': u''}

The correcponding deployment with dynamic pv + ops cluster DISABLED can be successful on the same env.


Version-Release number of selected component (if applicable):
openshift-ansible-playbooks-3.6.126.4-1.git.0.d25d828.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1.Deploy logging with the attached inventory file (dynamic pv + ops cluster enabled)

Actual results:
deployment failed

Expected results:
deployment should succeed

Additional info:
full ansible execution log attached
both the inventory file attached:
dynamic pv + ops cluster enabled --> the failed deployment
dynamic pv + ops cluster disabled --> the succeeded deployment
Comment 1 Xia Zhao 2017-06-30 05:46:33 EDT
The error message seemed to be related with this trello card in 3.6:  https://trello.com/c/XbNceey9/154-make-pvc-storageclass-annotation-immutable

Storage team members told that they have a recent change in 3.6 to prevent patch update pvc annotations.
Comment 2 Xia Zhao 2017-06-30 05:57 EDT
Created attachment 1293178 [details]
ansible execution log
Comment 3 Xia Zhao 2017-06-30 05:57 EDT
Created attachment 1293179 [details]
the inventory file when dynamic pv + ops cluster disabled --> the succeeded deployment
Comment 4 Scott Dodson 2017-06-30 10:52:58 EDT
Already fixed in https://github.com/openshift/openshift-ansible/pull/4651
Comment 6 Xia Zhao 2017-07-05 02:41:57 EDT
Issue fixed well, logging deployment can succeed with this bug fix.

ansible version tested with:

# rpm -qa | grep ansible
openshift-ansible-callback-plugins-3.6.133-1.git.0.950bb48.el7.noarch
openshift-ansible-docs-3.6.133-1.git.0.950bb48.el7.noarch
openshift-ansible-lookup-plugins-3.6.133-1.git.0.950bb48.el7.noarch
openshift-ansible-filter-plugins-3.6.133-1.git.0.950bb48.el7.noarch
openshift-ansible-playbooks-3.6.133-1.git.0.950bb48.el7.noarch
ansible-2.2.3.0-1.el7.noarch
openshift-ansible-3.6.133-1.git.0.950bb48.el7.noarch
openshift-ansible-roles-3.6.133-1.git.0.950bb48.el7.noarch


$ oc describe $es_pod:
...
  elasticsearch-storage:
    Type:	PersistentVolumeClaim (a reference to a PersistentVolumeClaim in the same namespace)
    ClaimName:	logging-es-0
    ReadOnly:	false
Comment 8 errata-xmlrpc 2017-08-10 01:29:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.