Bug 1466744 - Include docker.yaml and docker-ha.yaml environment files by default
Summary: Include docker.yaml and docker-ha.yaml environment files by default
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 12.0 (Pike)
Assignee: Dan Prince
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks: 1538015
TreeView+ depends on / blocked
 
Reported: 2017-06-30 11:20 UTC by Marius Cornea
Modified: 2018-02-05 19:10 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1538015 (view as bug list)
Environment:
Last Closed: 2017-12-13 21:37:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1701532 None None None 2017-06-30 11:20:50 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Marius Cornea 2017-06-30 11:20:10 UTC
Description of problem:

Currently when deploying a containers environment with pacemaker enabled we need to pass docker.yaml and docker-ha.yaml environment files to the overcloud deploy command. Since the deployment should be containerized by default I propose to include these environments files by default and not require the user to specifically pass them to the deploy command. Having to pass many environment files can become confusing for the user.

Comment 1 Dan Prince 2017-07-07 15:00:56 UTC
Defaulting environments could get tricky too. Are we defaulting the previous downstream templates in this regard? What I mean is are we for example automatically including environments/puppet-pacemaker.yaml downstream?

Comment 2 Omri Hochman 2017-07-07 15:12:45 UTC
after bug triaged meeting - we said it might be an RFE , but not sure that having this as default is what we really want. 

Need info PM

Comment 3 Marius Cornea 2017-07-07 15:31:22 UTC
(In reply to Dan Prince from comment #1)
> Defaulting environments could get tricky too. Are we defaulting the previous
> downstream templates in this regard? What I mean is are we for example
> automatically including environments/puppet-pacemaker.yaml downstream?

Yes, please see bug 1406869 as reference for OSP11.

If all the testing architectures and implicitly supported deployments include these environment files then why not include them by default? This way we could avoid failed deployments caused by a missed environment file. Moreover in case of upgrades missing one environment file may possibly have destructive consequences for the overcloud.

Please consider that passing environment files is a manual operation which is error prone. We should try to avoid this for better usability.

Comment 4 Jaromir Coufal 2017-07-18 21:20:23 UTC
I agree it should be by default and not a manual step for end users. I would not even consider this as an RFE, more of a user experience bug.

Comment 5 Dan Prince 2017-08-26 14:37:26 UTC
I've pushed a patch to inject the default docker.yaml and docker-ha.yaml environments downstream only:

  https://code.engineering.redhat.com/gerrit/116444 Include docker.yaml and docker-ha.yaml by default

Comment 6 Dan Prince 2017-08-27 12:35:27 UTC
We'll also need to directly patch t-h-t for this too I think because customers could be using a variety of the environment/services/ templates which when using docker live under environment/services-docker. Automatically switching these could get dirty though as we'd need to exclude Neutron, Cinder, and Manila services. The safest/cleanest thing to do just seemed like editing tripleo-heat-templates. So this patch in addition to the one above:

https://code.engineering.redhat.com/gerrit/116463 Default supported services to docker

Comment 8 Dan Prince 2017-09-19 15:25:35 UTC
Should be able to verify this by removing docker.yaml and docker-ha.yaml from the CLI. Additionally the UI should now always have these enabled by default.

Comment 9 Alexander Chuzhoy 2017-09-20 13:45:27 UTC
Verified:
openstack-tripleo-heat-templates-7.0.0-0.20170913050524.0rc2.el7ost.noarch
openstack-puppet-modules-11.0.0-0.20170828113154.el7ost.noarch
instack-undercloud-7.4.1-0.20170912115418.el7ost.noarch


Deployed without including docker.yaml and docker-ha.yaml and ended up with containerized deployment.

Comment 10 Rhys Oxenham 2017-10-10 09:24:51 UTC
Also verified here...

openstack-tripleo-heat-templates-7.0.1-0.20170927205938.el7ost.noarch
openstack-puppet-modules-11.0.0-0.20170828113154.el7ost.noarch

Worth noting that if you *do* include docker.yaml (and not docker-ha.yaml) on the CLI, an overcloud build will fail with the downstream templates as the VIP's aren't satisfied by pacemaker, even in a single controller environment.

Comment 15 errata-xmlrpc 2017-12-13 21:37:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.