Bug 1466762 - Running the config.yml playbook fails on the second run [NEEDINFO]
Running the config.yml playbook fails on the second run
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Russell Teague
Gan Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-30 08:11 EDT by Russell Teague
Modified: 2017-08-16 15 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When openshift_image_tag is specified in an inventory as on 3.X instead of a full tag of 3.X.x.x, the evaluation of `openshift_image_tag >= LooseVersion('3.X.0.0')` would result in False. This caused the condition to be improperly applied to logic elsewhere in the code resulting in invalid evaluation of version specific facts. The version comparisons have been updated to compare against the terse minimum version of '3.X'.
Story Points: ---
Clone Of: 1443416
Environment:
Last Closed: 2017-08-10 01:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
xtian: needinfo? (rteague)


Attachments (Terms of Use)

  None (edit)
Comment 1 Russell Teague 2017-06-30 08:13:37 EDT
Proposed: https://github.com/openshift/openshift-ansible/pull/4645
Comment 4 Gan Huang 2017-07-06 03:31:45 EDT
Could anyone answer https://bugzilla.redhat.com/show_bug.cgi?id=1443416#c11?

Should QE verify this bug by setting "openshift_image_tag=v3.6" which should not be a valid usage in QE's experiences?
Comment 6 Gan Huang 2017-07-12 08:45:35 EDT
Move to verified with openshift-ansible-3.6.140-1.git.0.4a02427.el7.noarch.rpm

No such error while setting "openshift_image_tag=v3.6" in containerized HA installation.
Comment 8 errata-xmlrpc 2017-08-10 01:29:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.